This project is read-only.

publish from vs2010 - doesnt work?

Nov 1, 2010 at 5:45 PM

Is there a correct way to publish an orchard site? I prefer to precompile my sites, so I ran the Publish option and copied the resulting output to my server. It quite obviously doenst include enough files to be complete tho, and errors on load.

what is the "correct" way to publish this app?


Nov 1, 2010 at 9:26 PM

nobody? I can't imagine this is difficult...

Nov 1, 2010 at 9:39 PM

I'll post an answer. Thanks for your patience.

Nov 2, 2010 at 12:13 AM

It should work if you deploy all files.

Nov 2, 2010 at 12:14 AM

I click the "Build", then "publish" menu options. It only produces 2 folders and a few files. I'm copying all these but Im pretty sure theyre not everything...

Nov 2, 2010 at 12:18 AM

Ok i just ran Publish on Orchard.Core as well, so this might be the solution. Appears I need to publish Core plus Web.

Nov 2, 2010 at 12:20 AM

You should publish all modules. All files under the web project.

Nov 2, 2010 at 12:52 AM

1. open the .sln file under /src

2. 3 projects and 5 virtual folders are included.

3. select orchard.web, click build, then publish.  -- this only outputs a few files.

4. select orchard.core, click build, then publish -- i just deployed this output and it still errors, even though it contains substantially more files in the output folder.



Nov 2, 2010 at 1:29 AM

You need to force the publication of all files, even those not referenced by the projet. Otherwise, you are going to miss all modules and all themes.

Nov 2, 2010 at 3:29 AM

these are the only two projects within the solution which have "publish" enabled for them. that's my source of confusion.

perhaps the project doesnt support precompiled publication?

Nov 2, 2010 at 3:37 AM

It doesn't. That's what I've been trying to say for a few messages... :) You need to publish the whole thing, with all the files, even those that are not referenced by the web project.

Nov 2, 2010 at 3:40 AM

ok, we got our term "publish" mixed up. Sounds like I need to copy the source dir to the server, ie it does *not* support preompiling. Thanks

Bummer that it doesnt, but I guess it cant be avoided.

Nov 2, 2010 at 5:31 PM

If you really want to use the Publish feature of VS 2010 then you need to change the publish settings for Orchard.Web project to include all files under project folder. At least when tested locally this produces a fully working Orchard. Of course you can still exclude debugging symbols and such.

Nov 2, 2010 at 5:43 PM

FFunny, i was *just* now trying this option, and it appears to be the right one ;) thanks for the help.