5

Resolved

Migrated taxonomy-based projection pages show up empty in 1.7

description

Projection pages using a simple unordered list layout on a projection built using Contrib.Taxonomies show up empty after upgrade to 1.7. Preview of the query gives results, it's only empty on the front end.

comments

x0r wrote Jun 30, 2013 at 9:05 PM

+1 strangely, preview in admin zone yields results

x0r wrote Jun 30, 2013 at 9:26 PM

This seems to be not only page related issue. Projector also comes up empty for Navigation (taxonomy based) Query Link

BertrandLeRoy wrote Jul 3, 2013 at 7:14 PM

Changing the layout to default doesn't improve things.

sebastienros wrote Jul 7, 2013 at 7:28 PM

Can you check with the latest release as of now, I think this is actually a bug in Projections, where is no Sort criteria is provided it would fail.

BertrandLeRoy wrote Jul 7, 2013 at 9:41 PM

Trying now.

BertrandLeRoy wrote Jul 7, 2013 at 9:57 PM

Yup, it's fixed.

BertrandLeRoy wrote Jul 7, 2013 at 9:58 PM

Ah wait, not in widgets.

BertrandLeRoy wrote Jul 7, 2013 at 10:17 PM

Taxonomy menu widget seems to be missing the new part. Filing a new bug for that.

x0r wrote Jul 7, 2013 at 10:56 PM

Pages using taxonomy are fine, thank you!

I'm displaying taxonomy menu using projector (query link), which still throws a sort related error (Ambiguous column name 'Id'. ORDER BY items must appear in the select list if SELECT DISTINCT is specified.). Adding sort criteria displays results in the backend, but frontend (navigation) comes up empty.

I can still replicate the sort issue with a simple projector query filtered to content type blogpost (adding sort criteria fixes it).

I'm using latest 1.x revision (7193) and i've rebuilt the solution to make sure.

sebastienros wrote Jul 8, 2013 at 2:04 AM

Widget has its own bug tracked