1

Resolved

Upgrade Lucene.Net to 3.0.3

description

See http://lucenenet.apache.org/download.html

Would it be possible to include Lucene.net.contrib and Lucene.net.contrib.spatial
http://nuget.org/packages/Lucene.net.contrib
http://nuget.org/packages/Lucene.net.contrib.spatial

A discussion had been opened a year ago :
http://orchard.codeplex.com/discussions/281676

comments

sebastienros wrote Oct 26, 2012 at 11:21 PM

ICSharpCode is a dependency. It's problem right now as it is GPL, and would break the changes we made to be complient with MySql licence.

Jetski5822 wrote Jun 9, 2013 at 9:47 AM

Might be okay... Looks like they have an exception for just our case...

http://www.icsharpcode.net/opensource/sharpziplib/

sebastienros wrote Jul 7, 2013 at 12:51 AM

Fixed in changeset 9a07137a68c2

sebastienros wrote Jul 7, 2013 at 12:52 AM

I have upgraded to 3.0.3 but not included the Contrib dlls though. I have to see what it provides and if it can be included in the default search interface, which I doubt.

But you could really easily create another module including those ones and provide extra features.

Jetski5822 wrote Jul 8, 2013 at 5:16 PM

How is our licencing model affected?

sebastienros wrote Jul 8, 2013 at 6:30 PM

I didn't have to link ICSharpZipLib, I assume it's only needed by the Contrib project, so no changes

sfmskywalker wrote Mar 28 at 1:28 AM

Fixed in changeset a39f56837a21fa3c9f69cc80e5a03751a953bd48