Why doesn't Orchard run out of the box?

Topics: General, Installing Orchard, Troubleshooting
Mar 22 at 10:42 PM
So I've installed Orchard, using the web platform installer, and then after that was done I've loaded Visual Studio 2015. Since there was no "SLN" or "CSPROJ" file in the main project folder, I did "Open Web Site"

When I try to run, I get errors. Something about "Lucerne.csproj" and "object reference not set to an instance of a class" like that was a source code file instead of a project file.

I really want to like Orchard but it just frustrates the hell out of me. Why doesn't this just work out of the box? Why should I have to fart around with it before I can do even the most simple little thing?
Developer
Mar 23 at 1:27 PM
I just tried installing Orchard from the Web Platform Installer. Although I'm not seeing the same issues you mentioned, I do experience the following:
  1. Orchard is installed.
  2. WebMatrix is launched.
  3. IIS Express is launched.
  4. The site is loaded, but with a YSOD stating that "A 'script' named 'jQuery' could not be found".
So something definitely seems to be broken there.
I created an issue for it: https://github.com/OrchardCMS/Orchard/issues/6641
Mar 23 at 5:03 PM
Everything works OK for me in WebMatrix, but given that the download is sprinkled with Visual Studio project files everywhere, it should also work in Visual Studio, and it doesn't.

Why use VS instead of WebMatrix? Well for one thing, you can't debug in WebMatrix.
Developer
Mar 26 at 11:13 AM
If you're interested in debugging then I recommend working with the Full Source distribution instead, which you can download here: https://github.com/OrchardCMS/Orchard/releases/download/1.10/Orchard.Source.zip