This project is read-only.

edit placement throws exception

Topics: Administration, Core
Mar 9, 2016 at 4:06 PM
When I click edit placement button, in the log I got lots of exceptions with error:

System.NullReferenceException: Object reference not set to an instance of an object.
at Orchard.ContentTypes.Services.PlacementService.<>c__DisplayClass40.<BindPlacement>b__3f(String partShapeType, String differentiator, String defaultLocation)
at Orchard.ContentTypes.Services.PlacementService.<ExtractPlacement>d__2d.MoveNext()
at System.Collections.Generic.List1.InsertRange(Int32 index, IEnumerable1 collection)
at Orchard.InvokeExtensions.Invoke[TEvents](IEnumerable1 events, Action1 dispatch, ILogger logger)
2016-03-09 15:51:27,369 [17] Orchard.ContentTypes.Services.PlacementService - Default - NullRefer

We can still input an article or create new article types, but the edit placement function just not working.

This problem happened on our live server and my local install doesn't have the same problem.

I tried to edit default content type (e.g. audio) or content type I created, they throw the same error. Does anyone have experience on what could be the problem?

Many Thanks