This project is read-only.

Orchard Project: Login Takes Me to Home Page

Topics: Administration
Feb 12, 2015 at 10:19 PM
I am new to the Orchard world and do not know for sure what version of Orchard we have, but it is NOT the newest (1.6?)? A couple weeks ago, I needed to access the Dashboard for a website my organization has. Using instructions at this site:
I was able to set the admin password to something simple to get in, login, reset the admin password to something "real", create a user for myself, login as myself and do what I needed to do. Everything worked fine, with no problems.

This week, when I try to log in, even after running the procedures at
again, I still cannot get in. When I click on the Sign-in link (upper right), regardless of the page I am on, it takes me back to the home page. I noticed from my reading that others have had this problem also.

Some points regarding how to solve the problem are still a unclear to me.

First, this is where things are right now.
In my SQL server database, I have a simple password for the admin users, with PasswordFormat set to Clear, per the instructions. There is a PasswordSalt still.

With this application the SQL sever database is on a different machine than the website.

On the machine hosting the website, I went into the IIS Manager, and unchecked "Automatically generate at runtime", per the instructions at this site: Tried to log in, but it did not help.

I read also that some folks solved the problem basically by also unchecking the "Generate a unique key for each application" also. When I deleted the Isolate part at the end of the key, it unchecked the checkboxes for "Generate a unique...". Tried to log in, but it did not help.

I added an entry to the Web.config file at the root of the site, for <system.web> <machineKey... per the instructions in the Setting-up-a-machine-key page. Tried to log in, but it did not help.

I am wondering if the entry for the PasswordSalt in the database must change, since I changed the machineKey stuff. If it must change, what should it be now?
Feb 13, 2015 at 12:29 AM
Edited Feb 13, 2015 at 12:29 AM
It's like you are already Authenticated but without a valid signed in user, that would explain why you are redirected to the home page and why this homepage only display the "log on" link

To reset this context, in the address bar of your browser, input manually and go to this url: "...YourSite.../Users/Account/LogOff". Then, retry to log in

Feb 17, 2015 at 5:41 PM
Thanks for the input. :-)

I entered the [mySite]/Users/Account/LogOff per your suggestion. It returned me to the home page ( http://gisweb2/site/ ).

Then I tried to log back in. It took me back to the home page again, but this was in the url: "http://gisweb2/site/?__r=8d218efba6b941f".
Feb 19, 2015 at 1:27 AM
Edited Feb 19, 2015 at 5:52 AM
I try to repro your issue, but, for the machine key, I've not the same context, I use IIS Express (not IIS) on my local machine. So, if it's due to a specific IIS configuration, I can't repro...

The weird parameter in your url is a refresh key, this means that you use the output cache module (with a max age setting > 0) and this key is used on a post redirection to render a new version of your page (not the cached one). Normally, this means that a logon post action has been taken into account. It's like your logon form has been automaticaly submitted without have been displayed! Do you have a specific "Logon.cshtml" in your current theme Views folder. If so, try to rename it

It's like you have an auto login somewhere, e.g with a browser plugin, can you check your browser extensions

I think you have already tried to completly stop and restart your site, clear all your browser caches and cookies, try with another browser... Do you have some infos in your log file? Now, what happen if you go to this url "YourSite/Admin" ? Try also this url "YourSite/Users/Account/ChangePassword"

If you can share your site url by email (via my codeplex profile), I can try to go to the logon form...

By reading the code, when you set the "PasswordFormat" to "Clear" then the "PasswordSalt" isn't used. With an Orchard 1.6 version, I've tried to "Clear" a password via the database, it works as described in the Bertrand's blog. Can you try to set the machinekey only via the web.config but without the part ",IsolateApps" as I've read in a forum...

Hope it can help