This project is read-only.

Vanilla setup error

Topics: Installing Orchard, Troubleshooting
Nov 15, 2014 at 1:21 PM
I have been trying to migrate my Orchard installation to a new server (the old one doesn't support ASP.NET 4.5). Unfortunately I can't get it working. At the moment, I have pushed a vanilla version to my webhost, connecting to an empty MSSQL database. I Always seem to be getting the exact same error message:

Setup failed: None of the constructors found with 'Orchard.Environment.AutofacUtil.DynamicProxy2.ConstructorFinderWrapper' on type 'Orchard.Security.Authorizer' can be invoked with the available services and parameters:
Cannot resolve parameter 'Orchard.Security.IAuthorizationService authorizationService' of constructor 'Void .ctor(Orchard.Security.IAuthorizationService, Orchard.UI.Notify.INotifier, Orchard.IWorkContextAccessor)'.

Doesn't really matter whether I upload a back-up of my site, use the existing or an empty database, it always throws this error either in the logs or on screen during the setup procedure. I'm kind of lost, unfortunately since it's an ISV hosting I do not have access to the server apart from FTP and Plesk. Any ideas to what I could try?
Nov 15, 2014 at 9:51 PM
Which Orchard version is this?
Nov 16, 2014 at 12:09 PM
The vanilla install was the latest build, 1.8.1. The site I'm trying to move is 1.6, but I wanted to make use of the opportunity to migrate. I also tried moving the 1.6 site one-on-one, to no avail.
Nov 16, 2014 at 9:31 PM
So moving the 1.6 site without any changes other than updating the DB connectionstring fails with the same error?
Nov 20, 2014 at 6:53 PM
I took a different approach, first installed the vanilla version on-prem and recreated the pages I had (were only a few fortunately). Imported my custom modules and configured the entire thing. Then backed-up the database and restored it online, afterwards uploaded the site itself. It now works although I do not exactly know what is different.