This project is read-only.

Unable to run Orchard in Azure

Topics: Administration, General, Installing Orchard, Troubleshooting
Aug 28, 2014 at 5:04 PM
This is the notorious ServiceRuntime/msshrtmi issue. Whether using VS2012 or VS2013, with Azure SDK 2.3 or 2.4 installed, I cannot get around this issue. Is SDK 2.1 literally required? I've been assuming the documentation is simply out of date, as SDK 2.1 and 2.2 are no longer available from the Web Platform Installer.

I've done the "Copy Local" thing, which simply shifted the issue from ServiceRuntime to msshrtmi. I've tried updating the assembly references to the 2.4 version of ServiceRuntime, but then even "Copy Local" doesn't do anything. I've been using the Publish menu item on the CloudService project, as documented, because ClickToBuildAzurePackage.cmd fails because it can't find AzurePackage.proj.

So I tried manually installing SDK for VS 2012 2.1, and the solution complained that it was created for a different version when I opened it. So I uninstalled 2.1 and manually installed SDK for VS 2012 2.2. and It complained that it couldn't find SDK 2.1. So I manually added 2.1 side-by-side with 2.2 and it still complained that it couldn't find 2.1.

At this point I'm at a complete loss. There seems to be no workable discussion of this anywhere searchable on Codeplex or anywhere else on Google/Bing. Has anyone on the development team actually confirmed functional deployment of Orchard from a fresh sources download using a clean install of VS 2012 or VS 2013 in the last two years? It would be really fantastic to have up-to-date, accurate documentation on the Azure deployment process, since what is currently documented does not work.
Aug 28, 2014 at 7:34 PM
At Sebastien's recommendation, I tried a Web Site deployment, instead of Cloud Service. It seems to have worked just fine, with SDK 2.4 for VS 2013 installed.
Marked as answer by MatthewPeck on 8/28/2014 at 11:35 AM
Sep 9, 2014 at 10:33 AM
Faced the same problem - what worked for me was upgrading MVC related assemblies to the latest (v5.2.2 as of this post) and it started behaving itself.
Seems to be more than a few problems if you wish to deploy Orchard as a cloud service (and I do I can get used to having dual production/staging environments)