URLs problem

Topics: Administration, Customizing Orchard, General
Aug 8, 2014 at 4:26 PM
How can we get rid of the random characters appended to the URLs of orchard websites?
thank you!
Aug 8, 2014 at 5:47 PM
Which ones ?
Aug 8, 2014 at 6:19 PM
do you have the output cache module switched on?

Aug 10, 2014 at 10:07 AM
how can i find the cache module sw on? can you be more exactly?
this is the problem : http://postimg.org/image/tfz6ub951/
Aug 11, 2014 at 12:17 AM
You can see what features are enabled by going to the Modules section and filtering on OutputCache.
Aug 11, 2014 at 6:52 AM
Yes, i checked and the module output cache is enable - something else ? any ideea?
thank you very much!
Aug 11, 2014 at 6:57 AM
Edited Aug 11, 2014 at 6:58 AM
The Output Cache filter adds a querystring called "__r" upon a redirect after a POST. But looking at your screencast, it looks like you're seeing something else. I have never seen a hash tag being added by Orchard. Can you reproduce this issue with a clean Orchard installation? Perhaps a 3rd party module is doing this?
Aug 11, 2014 at 7:15 AM
Maybe it happens beacause right now i use a subdomain like mysite.domain.com?
Aug 11, 2014 at 7:43 AM
I don't think so. I have sites running on subdomains, and I don't see that behavior.
Can you reproduce this issue with a clean Orchard installation?
Aug 11, 2014 at 7:59 AM
My guess is like skywalker said, a third party module is doing this. Maybe something like an image slider to enable the user to use the browser's back button.
Aug 11, 2014 at 8:29 AM
ok - let me to do some checks