Newbie: What version of ASP.NET MVC does the latest build use?

Topics: General, Writing modules
Aug 7, 2014 at 5:41 AM
I want to develop modules in ASP.NET MVC, but would like to know what versions of MVC are used in the different Orchard versions.

Aug 7, 2014 at 6:11 AM
Edited Aug 7, 2014 at 6:11 AM
I think the 1.x branch uses 1.5.1. Not sure about 1.8, but if you download it, you can inspect the product version on the System.Web.Mvc.dll file (in lib/aspnetmvc).
Aug 7, 2014 at 6:21 AM
Good advice!

I have do so, and just for the record, the latest 1.8 uses MVC 5.1

Aug 7, 2014 at 6:43 AM
I think 1 - 1.6 uses MVC3, 1.7&1.8 MVC4 and the latest 1.8.1 MVC5 if I recall correctly. But if you're a beginner, I imagine you only have to know about the latest (which you'll probably gonna use)
Aug 7, 2014 at 6:45 AM
This is a great help, as I may have to support a previous version.