This project is read-only.

How to compose the favicon URL?

Topics: Troubleshooting
Jul 30, 2014 at 3:37 PM
I posted this question at the discussions of Vandelay Industries about a week ago. Since I have not got any response, I am trying my luck here.

I have the following favicon:

I have tried all sorts of URLs, but none has worked. Could any one provide a tip on how to compose the URL for the above icon?
Aug 1, 2014 at 1:38 AM
Not sure. Maybe you need to include the tenant name? E.g. ~/Media/Default/favicon/favicon.ico
Aug 1, 2014 at 1:49 AM
Thank you for the response. Do you happen to know a working example of favicon?
Aug 1, 2014 at 1:51 AM
You're welcome. I was about to say: "sorry I don't", but suddenly remembered that my very own site is using this feature.
I am using this value:

Aug 1, 2014 at 1:52 AM
Also, when you change your value, make sure to clear your browser cache and restart your browser. I remember having troubles with getting the favicon to appear in IE.
Aug 1, 2014 at 2:55 AM
Thanks a lot for the tips. I did exactly what you do for your site except the icon file name is favicon.ico instead of favicon.png. It does not appear to be working.
After I click "save", the Favicon URL text field becomes empty. I am wondering if this is normal.
Aug 2, 2014 at 11:58 PM
Perhaps you need to add a MIME type for the .ico extension? Can you try with a PNG?
After clicking "save", the Favicon URL text field should not become empty, so this looks like a bug.
Are you using the latest version of the module?
Aug 4, 2014 at 3:04 PM
Thanks a lot for your persistent help.

I installed the module last week. I have just checked updates, and not seen any.

I tried favicon.png, but the issue was the same. Now the folder /Home/Media/Default/favicon has two files: favicon.ico and favicon.png, and "Suggestions" shows these two accordingly. If I click favicon.png, the URL is "/Home/Media/Default/favicon/favicon.png". After "Save" is clicked, the field becomes empty. I changed the URL to "~/Home/Media/Default/favicon/favicon.png", but the issue remained.
Aug 4, 2014 at 9:00 PM
OK, then that looks like a bug. If you can reproduce this issue with a clean Orchard installation (1.8), then I recommend filing a bug on the project site for this module and contact the owner. Meanwhile you might want to try and debug the module. Perhaps start by looking at the log files, see if anything's there?
Another fun way of solving this issue is by creating a ticket on Orchard Pros - that way people earn points by looking into your issue.
Marked as answer by zipswich on 8/5/2014 at 7:07 AM
Aug 5, 2014 at 3:07 PM
Thank you for the suggestions.
The log does not have anything.
I will install a new instance of Orchard when I find the time, and debug from there.
Thanks again for all the help.
Jan 14, 2016 at 11:05 PM
This Vandelay module is waste for favicon. I am facing the same problem and not able to update the favicon.
This is a confirmed bug of Vandelay module. I have tried on Orchard.