This project is read-only.

I am not successful in applying themes on a azure deployed orchard project

Topics: Administration, Customizing Orchard
Jul 1, 2014 at 1:57 PM
I am hoping someone can point me to what I am doing wrong. I have successfully deployed a "default" configuration orchard 1.8 site to Azure. I am currently attempting to apply one of the available themes. It is not working, and appears as if it is not applying the style sheets to the pages.

1) I followed the "deploy to azure" steps line by line, and have gone back and double and triple checked.
2) the Site works with the default styles.
3) I can admin the site
4) when I apply a theme from the "installed" themes, it changes the look of the page, but mainly layout. no colors, no styling.

Can anyone spare a few minutes to help?
Jul 10, 2014 at 3:42 AM
Okay, I am getting frustrated. I tried again. this time with 1.8.1. the site deploys and runs, it shows the themes when I install them. but when I apply, it does not work.

This is a single instance Azure deployed 1.8.1 Orchard site. Default settings, DB in SQL Azure.

Am I missing something fundamental? did I forget a step, a setting, a config in azure?

Anyone help?
Jul 10, 2014 at 6:34 AM
Did you deploy to Azure Websites? Which theme are you trying to use?
Jul 10, 2014 at 8:54 PM
I deployed to Azure Cloud services using the walkthrough in the doc's. it applies directly to 1.7, but the steps are pretty straight forwards. configuring of storage, changing the settings to reflect the key and storage accounts.

I used vs2013, downloaded the source zip, and unzipped. opened the Orchard Azure project and did some test builds. Got a couple of warnings regarding log4net in the Orchard.Web project not being copied local. resolved all of the warnings.

I deployed, it went through the standard db setup. I was able to add modules (the azure ones for caching and such, once again, per the instructions).

I can go to the themes page, select one. it claims it is downloaded and installed.

I select and ask it to apply (the ones I have tried are Terra and City (sp?)). it does seem to effect layout, but no graphics or colors or styling is applied.

I made sure my storage was not read only, I checked the db and it is full of what looks to be the correct tables.

Am I missing something?
Jul 10, 2014 at 10:29 PM
Okay, debugger is showing a 500 error when I try and get the css for citytheme.

when I am running in azure does it still try and write to the file system when you download a theme? Do I need to get the theme files and put in the package before I upload?
Jul 17, 2014 at 9:12 AM
I had a similar problem with my deployment to Azure Cloud, it does however work on Azure Web Sites, not sure if its the same problem though.

As far as I can see (and have been told) its an Azure Cloud service issue.

It may or not be relate to you, try an Azure web site deployment and see if that works maybe?
Jul 17, 2014 at 11:16 AM
You are not meant to add any modules or themes post-deployment for Azure Cloud Services, because if the fabric controller decides to reimage your instance, or spin up more instances of your role when you request to scale out for example, your downloaded stuff would be gone. You have to add the theme locally to the solution before deployment, in the correct location, and also add a project reference to it from the Orchard.Azure.CloudService project. Hope this helps.