Suddenly no Admin login possible! Reset doesn't seem to work? Help!

Topics: Administration, Core, General, Troubleshooting
May 27, 2014 at 5:09 PM
I've been using Orchard for a while now on my local system and it worked ok. Today - after some weeks working on a different project - I wanted to adjust some stuff in the backend of Orchard.

However I was greeted with a password prompt. Up until now I was automatically logged in and never had to provide a password.

I have not changed anything lately, this change seems to "have just appeared out of the blue"

I tried a couple of stanrad passwords but none worked.

I remembered that I had a test install using WebMatrix (my main project is in VS2013 Pro). I tried that one and it, too, wanted an admin password from me.

I found this old article about how to reset your password: http://weblogs.asp.net/bleroy/archive/2011/04/28/recovering-the-admin-password-in-orchard.aspx

I followed the steps and set "banana" as temporary password. However it does not work. The Text will still say that the password is incorrect! I'll always end up back at http://localhost:35366/Users/Account/AccessDenied?ReturnUrl=%2FAdmin%2FContents%2FList


Please help! There is a lot of work in my Orchard project so far and we were just discussing a timeframe to update the content and the publish it to repace our old website!
May 27, 2014 at 5:55 PM
The resetting of the password is different now. Check this discussion:

https://orchard.codeplex.com/discussions/545562
Jun 2, 2014 at 8:37 AM
The method in the linked thread worked for me. Thank you very much!