Multi Tenancy, seperate domain, problems with www.

Topics: Administration
Apr 24, 2014 at 9:26 AM
We've setup multi tenancy and have added a tenant (second domain) and can see both the default and the tenants domain when using the standard URL of www.thename.com The problem is that on the tenants site we cannot get the both http://www.tenantname.com http://tenantname.com to work. It's one or the other depending on the settings in "Tenants" in the default domain and the other url then defaults to the default site. Urls below

http://www.snowbeds.com
http://snowbeds.com

Tenant:

http://www.muddybeds.com
http://muddybeds.com (defaults to the snowbeds site.)

How do we get both url's to work on the 2nd site?
Developer
Apr 24, 2014 at 12:19 PM
If you want your tenant to listen to both the www and non-www URL then you should both of them to the tenant's RequestUrlHost config (you can do that from the multi tenancy admin page), comma separated, eg.: "snowbeds,com,www.snowbeds,com".

But I'd suggest you to instead redirect one version to the other with IIS rewrite rules.
Apr 24, 2014 at 12:51 PM
I'd setup both, so I've tried swapping them over and it's taking just the first entry and ignoring the 2nd. Do we know if that is a bug that is fixed in 1.8? We are using Orchard 1.7.2.0
Developer
Apr 24, 2014 at 9:07 PM
Hmm, this should work and I don't think there is such a bug in 1.7.2 (neither 1.8). If you tell the specific config you have in all of your Settings.txts then probably we can tell if there is still an issue with the setup.
Apr 25, 2014 at 7:20 AM
Here's the default site (snowbeds):

State: Running
Themes:
Name: Default
RequestUrlHost: null
RequestUrlPrefix: null
DataProvider: SqlServer
DataConnectionString: sql datasource
DataTablePrefix: snb
EncryptionAlgorithm: AES
EncryptionKey:
HashAlgorithm: HMACSHA256
HashKey:

Here's the Muddybeds site:

State: Running
Themes: Bootstrap
Name: Muddybeds
RequestUrlHost: www.muddybeds.com, muddybeds.com
RequestUrlPrefix: null
DataProvider: SqlServer
DataConnectionString: same sql data source
DataTablePrefix: mb
EncryptionAlgorithm: AES
EncryptionKey:
HashAlgorithm: HMACSHA256
HashKey:
Developer
Apr 26, 2014 at 6:23 PM
This seems fine unfortunately (try to remove the space in Muddybeds's RequestUrlHost, just in case). By the way when your default tenant has null for RequestUrlHost then that will play the fallback if Orchard can't find a suitable tenant for a request, that's what you see.
Apr 26, 2014 at 6:27 PM
Nice one, the space is the problem, works fine now!

Should we raise this?
Developer
Apr 26, 2014 at 6:30 PM
Now I remember there is also an issue for this: https://orchard.codeplex.com/workitem/19617
Apr 26, 2014 at 6:48 PM
It ought to be treated as a bug, because we setup using the gui. The helptext for Base url actually has a space separating out multiple entries, if we can't get the code fixed then a quick update to the helptext in admin would ease the process.

Thanks for you help.