Uograde to 1.8 problems

Topics: Administration, Customizing Orchard, General, Installing Orchard
Apr 1, 2014 at 1:56 PM
Hi,

I have been trying to upgrade to 1.8 and this is the first Orchard upgrade I have ever done. I am having major problems doing this! Can anyone direct me to any specific instructions on how to do this?

In a nutshell this is what I did:-

Made a back-up of existing site

Downloaded the new 1.8 Orchard (web) zip.

I then copied the App_Data, Modules and Themes folder into the new version.

When I uploaded the new site via FTP (into a new folder) my home page was there but no menus or text content and no admin interface or link to admin?

Please can anyone offer any advice?

Many thanks in advance,
Kirsty
Apr 1, 2014 at 2:26 PM
Hello Kirsty,

I don't know if this is of any help, but I too am having issues with that zip. Please see an issue I raised earlier:

https://orchard.codeplex.com/workitem/20591

This might offer some pointers.

Good luck.
Apr 1, 2014 at 6:34 PM
Edited Apr 2, 2014 at 3:04 AM
kirstybash wrote:
When I uploaded the new site via FTP (into a new folder) my home page was there but no menus or text content and no admin interface or link to admin?
Hello,

I just upgraded my Orchard CMS site from V1.5.1 to V1.8.0.0

Please double check everything. What errors do u see in the logs folder?

Follow these instructions : http://docs.orchardproject.net/Documentation/Orchard-1-8-Release-Notes#UpgradingfromOrchard

After upgrading to Orchard CMS V1.8 you need to enable the Upgrade To 1.8 module and then migrate all the content which were created using previous version of Orchard CMS.

Can you please tell us from which version of Orchard CMS are u upgrading to V1.8?

Best

Abhishek Luv
Marked as answer by sebastienros on 4/1/2014 at 2:35 PM
Apr 2, 2014 at 12:24 PM
Edited Apr 2, 2014 at 12:47 PM
Hi Abhishek

thanks for your reply.

I am still trying to do this with no luck!!!! I am attempting to upgrade from 1.6 to 1.8.

I can only get as far as getting all the content from 1.8 with a home page that does not show my css settings and no admin! I typed in the URL to admin and tried to log in and it said access denied!

Just don't know what I am doing wrong! It is driving me crazy!!!

Some of the notes I have read say you need to set your permissions as site owner - how do you do this?
I am already admin with full rights on the site.

Any advice would be most welcome!

Thanks,
Kirsty
Apr 2, 2014 at 8:55 PM
Kirsty,

Your big problem now is that you didn't set the Site Owner to the Administrator Role, which means you won't be able to log into the website unless you apply the hack as mentioned in the release notes or start the upgrade process over again.

http://docs.orchardproject.net/Documentation/Orchard-1-8-Release-Notes

If you start over again, before you do the upgrade you need to login as an Administrator and assign the Administrator Role to whatever user you are using as the Site Owner. This is pretty easy to do by following the documentation:

http://docs.orchardproject.net/Documentation/Managing-users-and-roles

The website will look funny until you successfully log into the dashboard, enable the Upgrade 1.8 Module, and successfully migrate the various items via the upgrade module. Once you do that, the website should be working fine.


Regards,

Dave
Apr 3, 2014 at 9:30 AM
Thanks Dave for your reply.

I did some reading around the users and roles yesterday.
When I checked in the dashboard, I am set to Admin but all the Roles checkboxes were unchecked.
I have now checked them all and will begin the process again.

I am sill a bit confused about who is the site owner - I created the site, is there a set field for site owner anywhere?

Will give this another go now.

Thanks very much,
Kirsty
Apr 3, 2014 at 2:52 PM
kirstybash wrote:
I am sill a bit confused about who is the site owner - I created the site, is there a set field for site owner anywhere?
Hi ,

Go to Role you want to edit, and in the section "Orchard.Framework Feature" you will find "Site Owners Permission"
If you have problems to find this permission try to set the super user in "Settings".
Apr 3, 2014 at 11:10 PM
Kirsty,

The Site Owner is the same as the Super User. The username can be found in the Site Settings as shown here in the documentation.

http://docs.orchardproject.net/Documentation/Modifying-site-settings

Regards,

Dave
Apr 7, 2014 at 10:03 AM
Hi all

thanks for this info. I have now verified the admin user and made sure all checkboxes are checked and will give it another go.

Many thanks for the advice.

Kirsty
Apr 10, 2014 at 6:14 PM
Edited Apr 12, 2014 at 6:16 PM
I've used Url.Absolute in my queries to show images in 1.7 and it worked properly.
when i update to 1.8 images src attribute retrieve blank and this Rewrite text
<img src="{Content.Fields.Slides.Image.Url.Absolute}"/>
not work correctly and only show images for the first page load after running project!!!
can anybody help me?!?!?!