This project is read-only.

Multi-Tenant not working properly

Topics: Administration
Nov 27, 2013 at 1:05 PM
I have hosted the compiled source code on my localhost IIS7. I am trying to add tenant which is successfully completed but when i click set up option it gives me error could not found.

Tenant Details :

Name: Alpha
Host: alpha.localhost

Orchard generate the address like this : http://alpha.localhost:5000/
but its not working.

I also tried adding tenant without given localhost which is http://beta:5000/ but this is also not working.

Please advice.
Nov 27, 2013 at 8:00 PM
I guess this is not Orchard's fault but simply that your browser can't reach the address since it doesn't exist ("localhost" is not a "wildcard" and doesn't allow such subdomains without anything). See:
Nov 28, 2013 at 10:39 AM

I followed these two links and spend whole day by trying and testing but still not able to run it.



Please can you tell me step by step how can i configure it on localhost? either by using source code or webmatrix?
Nov 28, 2013 at 11:02 AM
What is the error you're seeing?
Nov 28, 2013 at 11:09 AM
same error always.. could not found.
Nov 28, 2013 at 11:16 AM
The red IIS 404?
Nov 28, 2013 at 11:28 AM
When i click set-up it opens this address


and says could not find alpha.localhost:18642
Nov 28, 2013 at 11:46 AM
You're making it really hard to help without telling the exact error you see. But to take another guess from the minimal information you gave I think the problem is that you haven't added the mapping between alpha.localhost and into your hosts file. If you have then clear the browser's cache, restart it and it should work (or maybe try to flush the DNS cache with ipconfig /flushdns but I'm not sure whether this is stored in the DNS cache too).
Nov 28, 2013 at 11:57 AM
Edited Nov 28, 2013 at 12:27 PM
let me tell you from scratch what i have done .

1) I downloaded the orchard using webmatrix and created new website with name of ClubMS
3) Enabled the tenant and add new tenant with following details

Name: Alpha
Host : alpha.localhost
Allow the tenant to setup the database.

it has generated the following address http://alpha.localhost:18642

Now i open the file from this location C:\Windows\System32\drivers\etc\hosts and added the line alpha.localhost

now when i try to run the site i see the error

Bad Request - Invalid Hostname

HTTP Error 400. The request hostname is invalid.

I have tried by emptying the cache and history but no luck
Nov 28, 2013 at 1:17 PM
So it's not not found. I'm not sure about the bad request. What happens without specifying the port?