This project is read-only.

Deployment to Azure

Topics: Installing Orchard
Nov 15, 2013 at 9:04 PM
I have a problem with publication Orchard 1.7.1 in Azure.

I follow this instructions link
but after publication I have error:

No such host is known
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Net.Sockets.SocketException: No such host is known

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[SocketException (0x2af9): No such host is known]
System.Net.Dns.HostResolutionEndHelper(IAsyncResult asyncResult) +3194209
System.Net.Sockets.Socket.DoDnsCallback(IAsyncResult result, MultipleAddressConnectAsyncResult context) +141
System.Net.Sockets.Socket.BeginConnect(String host, Int32 port, AsyncCallback requestCallback, Object state) +344
Microsoft.ApplicationServer.Caching.SocketConnectionFactory.BeginConnect(String host, Int32 port, AsyncCallback callback, Object state, TimeSpan timeout) +713
Microsoft.ApplicationServer.Caching.TcpClientChannelFactory.BeginConnect(String host, Int32 port, AsyncCallback callback, Object state) +160

What did I do wrong?

Maybe I make a mistake with cache configuration?

I tryed to disable cache but I had the same error.

What am I doing wrong

Nov 16, 2013 at 11:53 AM
First of all, are you deploying to a cloud service or a web site?
Nov 16, 2013 at 3:38 PM
I depoying to a cloud service.
Nov 16, 2013 at 4:43 PM
OK. From the stack trace it looks like something is misconfigured in your cloud service deployment config.

Can you post a screen shot of the Settings, Endpoints and Caching tabs in the Orchard.Azure.CloudService project please.
Also if you could post the Web.config file in the Orchard.Azure.Web project please.
Dec 5, 2013 at 7:25 AM
I have a problem deploying an orchard 1.7.2 to an Azure Cloud Service!

I followed the same steps as Whiteman and the deployment succeeded in Visual Studio. But if I visit the Website I'll get a runtime error with an advice to disable custom errors.

the strange this is, that I disabled custom Errors is web.config AND I enabled Remote Desktop Support while deploying, but nothing of this may take effect.

So I tried to start the orchard locally in the azure Emulator. I got an Autofac error, something was not registered. But I found an article which descripes how to run orchard 17.2 in azure Emulator. I copied the Folders Modules, Themes, Media and Core from the Orchard.Web Project to Orchard.Azure.Web. And it works!!!

BUT, why is there an error if I want to deploy to an Azure Cloud Service? I recreated the azure instances and so on... no effect.

Do you have any experiences deploying 1.7.2 to Azure??? Feel free to answer!

looking Forward to hearing from you