Problems in Loading Orchard Projects from Web matrix 3 to Visual Studio 2012

Topics: General
Sep 14, 2013 at 4:10 PM
Hi all the Members of Orchard Community!

Kindly help me in this problem:

I am working on orchard in Web matrix 3 but when I click Visual Studio tab NOT A SINGLE PROJECT of Orchard solution is loaded from Web matrix 3 to Visual Studio 2012. Only the name of the Solution is transferred there BUT not any file or project of the solution.



Thanking you in anticipation.
Coordinator
Sep 14, 2013 at 9:02 PM
Never use that button. Get yourself the full source code if you want to work with VS, and open orchard.sln from there directly.
Sep 15, 2013 at 6:25 PM
Edited Sep 15, 2013 at 6:39 PM
Thank you for quick response

I tried to get orchard cms from Web Platform Installer for visual studio 2012 but failed with the following message:

SORRY


http://go.microsoft.com/flink/?LinkId=221672#ERROR_SITE_DOES_NOT_EXIST.

Following is the Error Log:

DownloadManager Information: 0 : Loading product xml from: https://go.microsoft.com/?linkid=9824573
DownloadManager Information: 0 : https://go.microsoft.com/?linkid=9824573 responded with 302
DownloadManager Information: 0 : Response headers:
HTTP/1.1 302 Found
Cache-Control: private
Content-Length: 175
Content-Type: text/html; charset=utf-8
Expires: Sun, 15 Sep 2013 17:28:34 GMT
Location: https://www.microsoft.com/web/webpi/4.6/webproductlist.xml
Server: Microsoft-IIS/7.5
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
Date: Sun, 15 Sep 2013 17:29:33 GMT

Pl help!

Thank you in anticipation.
Coordinator
Sep 17, 2013 at 7:07 PM
If you are going to use VS, please use the full source code version.
Sep 19, 2013 at 1:11 AM
Edited Sep 19, 2013 at 1:17 AM
Thank you, now I understand the difference BUT when I open the solution following message is given:

" one or more projects in the solution are not loaded correctly. See the output window for details." This behavior is repeated all the times.

In the window following is given:

C:\Users\Basharat Ahmad\AppData\Local\Temp\Temp3_Orchard.Source.1.7.1.zip\src\Orchard.Web\Orchard.Web.csproj : error : The project file could not be loaded. Could not find a part of the path 'C:\Users\Basharat Ahmad\AppData\Local\Temp\Temp3_Orchard.Source.1.7.1.zip\src\Orchard.Web\Orchard.Web.csproj'. C:\Users\Basharat Ahmad\AppData\Local\Temp\Temp3_Orchard.Source.1.7.1.zip\src\Orchard.Web\Orchard.Web.csproj

What is the remedy for this malady?

Thank you again.

The Newbie
Coordinator
Sep 19, 2013 at 2:01 AM
Open src\orchard.sln instead.
Sep 19, 2013 at 3:35 PM
I apologize in advance for asking a question that sounds belonging to a pre-Newbie stage. Based on what I understood from your reply, I took following actions:
  1. What i downloaded as " full source code" was automatically named "Orchard.Source.1.7.1 on the desktop.
  2. Launched the VS
  3. Clicked the Open File.
  4. Tried to select the above-mentioned folder. But it could not be selected. Created a new folder named Orchard.sln and copied all the files in this folder.
  5. For complying your instruction [ src\orchard.sln], I tried many options but in vain.
  6. Now stuck
Seeking your providential help,

The Newbie
Coordinator
Sep 19, 2013 at 7:50 PM
Really?

Where to find the solution file
Sep 20, 2013 at 4:12 AM
Thank for gigantically benevolent response!

Following are the differences between the screen shot posted by you and the one on my desktop:
  1. Name of the download with me is without the suffix: 'zip.
  2. The orchard.sln file with me is without the suffix: 'sln'.
  3. On the left side there is no temp folder. I could not find it in spite of exploration.
  4. The result was the same as before.
Thank you so much for the continued help!

The Newbie
Coordinator
Sep 20, 2013 at 6:37 AM
  1. is because you extracted the archive, like you should. I was showing you in the zip file to show you that really, the file as downloaded from CodePlex does have the solution in it.
  2. is because you left Windows configured with the silly and dangerous setting that hides file extensions. I highly recommend that you change that setting in Windows Explorer options.
  3. temp is just where I downloaded the zip. Of course the unzipped folder will be wherever you put it.
o_O
Sep 21, 2013 at 7:35 AM
Thank you,
  1. I am searching how to reset the options in windows explorer. But the BEST WAY is to know from you where is the tab for setting the options for "WINDOWS EXPLORER' & what are the ideal or optimum options for windows 8.
    1. Change in an indicator: After the name of each file and folder, (unavailable) WAS given BEFORE YOUR SPECIFIC INSTRUCTIONS _ BUT after acting upon your instruction, (load failed), is given after the name of each file and folder .
Anxiously waiting for further help!

The Newbie
Coordinator
Sep 21, 2013 at 8:03 AM
Are you trolling me? Except for showing up at your place and doing it for you, there is no way I can give you more details. If that's not enough, I don't know what more I can do.
Sep 21, 2013 at 4:50 PM
Edited Sep 21, 2013 at 4:51 PM
Subject: APOLOGY
  1. My questioning you before reading the 32 pages regarding Windows Explorer and IE-10 ( that I had searched and printed) was morally and legally invalid because a student should first exert oneself and after one had exhausted oneself fully then one may take the liberty to bother a teacher. This was my mistake and I earnestly apologize for it.
    1. As a result of this reading I came to know that the Microsoft has probably replaced the term “Windows Explorer” with the term “File Explorer” because when I entered this term in the windows search the required scenario was before me i.e. the four libraries.
  2. The second question i.e. (unavailable) versus (not loading) was made OUT OF DESPERATION - - - that before reaching any level of perfection regarding configuration OR resetting files, may there be any possibility for one to be fruitfully rewarded for the three years spent (on Orchard + MVC) after 60 that repaid me only equivalent to three months on account of unfriendly environment.
  3. Actual game begins after Complete and flawless loading of Orchard in VS 2012, what a pity if one is stuck in JUST loading - - - -
  4. Now the turn is for the Benevolence - - - - -
Looking forward in anticipation,

The Newbie
Coordinator
Sep 22, 2013 at 3:06 AM
So to summarize, download the source code zip, extract it in some folder. Under that folder, find src. Under src, find Orchard.sln. Open that in VS.
Sep 22, 2013 at 2:16 PM
Edited Sep 22, 2013 at 2:17 PM
Hi Bertrand !

Thank you so much,
  1. The __cause of the failure __ was "Downloadable Orchard" was having zip suffix BUT "downloaded orchard" having no suffix at all serving as __a misleading pointer __for a Newbie, as if "the downloaded orchard" is already unzipped and is not meant for unzipping. Actually I was not unzipping the download.
  2. NEXT PROBLEM: Now the Orchard is downloaded in VS but debugging results into: "unable to launch the iis express web server" WHILE iis 1.8 express is installed on my computer.
Kindly Guide me.

The Newbie
Coordinator
Sep 22, 2013 at 9:06 PM
If your Windows is configured to not show file extensions, that cannot be blamed on Orchard. You are the first to do so, after several years of existence of the platform.
That your VS is not configured correctly would have to be taken to a forum about Visual Studio and/or IIS Express. Try the same thing with a blank site and see if that works.
Sep 23, 2013 at 3:17 AM
Edited Sep 23, 2013 at 3:51 AM
Thank you
  1. I have noted your instructions BUT I came to this Forum loaded with following indication that is displayed after clicking the Build Tab AFTER consulting stackoverflow.com where one of the 'ANSWERER' suggested to delete the IISExpress From the the Default Document Folder:
    9/22/2013 6:50:32 PM: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))
    at EnvDTE.Properties.Item(Object index)
    at MadsKristensen.EditorExtensions.ProjectHelpers.GetRootFolder()
    at EnvDTE.Properties.Item(Object index)
    at MadsKristensen.EditorExtensions.ProjectHelpers.GetRootFolder()
    9/22/2013 6:50:32 PM: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))
    at EnvDTE.Properties.Item(Object index)
    at MadsKristensen.EditorExtensions.ProjectHelpers.GetRootFolder()
    at EnvDTE.Properties.Item(Object index)
    at MadsKristensen.EditorExtensions.ProjectHelpers.GetRootFolder()
    9/22/2013 6:50:32 PM: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))
    at EnvDTE.Properties.Item(Object index)
    at MadsKristensen.EditorExtensions.ProjectHelpers.GetRootFolder()
    at EnvDTE.Properties.Item(Object index)
    at MadsKristensen.EditorExtensions.ProjectHelpers.GetRootFolder()
    9/22/2013 6:50:32 PM: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))
    at EnvDTE.Properties.Item(Object index)
    at MadsKristensen.EditorExtensions.ProjectHelpers.GetRootFolder()
    at EnvDTE.Properties.Item(Object index)
    at MadsKristensen.EditorExtensions.ProjectHelpers.GetRootFolder()
  2. The Answerer told that the deleted folder will automatically recreated BUT it is not created. Rather, when debugging following is displayed:
    (i) A project with an output type of class library can not be started directly.
    (ii) In order to debug , add an executable project to this solution which references the library project. Set the executable project as the start up project.
  3. BUT the system does not complain the absence of IISExplorer!
  4. I will configure VS and also window as instructed by you.
Thanking in anticipation,

The Newbie
Coordinator
Sep 23, 2013 at 4:13 AM
  1. I don't know why that person would recommend that, and for what, but what you're seeing in the output window is unrelated and can be ignored. It's a known problem caused by VS Web Extensions.
  2. You must have modified the solution. The startup project should be Orchard.Web. You can restore it by right-clicking the project in the solution explorer and choosing "Set as startup project". I don't know what "deleted folder" you are referring to.
  3. I don't know what that means.
Sep 23, 2013 at 3:54 PM
Hi Bertrand!
  1. I feel (God-willing) you will set me at the right track by and by.
  2. I found Orchard.Web project right at the very bottom of the Long list of folders and files in Solution Explorer. Orchard.Web is suffixed with (load failed). When I right click it, the menu does not show " set as start-up Project". Though, I twice downloaded the source code.
  3. Can a source code once downloaded can be extracted more than once?
Thank you for putting up with my trivial questions.

The Newbie
Coordinator
Sep 23, 2013 at 5:36 PM
  1. I already did. Ignore those warnings.
  2. You need to determine why the project doesn't load. It's probably because your IIS Express is broken. Fix that first.
  3. Of course.
Sep 24, 2013 at 12:31 AM
You might want to try starting VS as administrator (depending on your verison of windows, to do this right-click on VS icon, select Run as administrator, approve when windows asks if you are sure) before opening Orchard solution, in case it's IIS settings that prevent Orchard.Web project to load.


Sep 30, 2013 at 1:59 PM
Thank you kassobasi !

u have provided an insight that I will use at some later stage, BECAUSES, presnetely I have reverted from Windows 8 to Windows 7 and Source Code is loaded here nicely and now I intend to stick to this combination of a platform. However, I need answers to the following questions:
  1. Edit buttons in the Orchard home page are absent. I am using Orchard.Source.1.7.1.zip
  2. After the downlod, IIs 8.0 Express appears in the control panel BUT not the relevant Manager. I am doing with the Old iis 7 Manager.
  3. When creating a new page, the slot: "Show on the Main Menu" is still absent. Bertrand told me to go to content definition and so on - - - But the hierarchial subtlties involved in __item-type-part-field __ - - - - - defied the fixing (Which is which i.e. whether "Show on the Main Menu" is part or field) ! Kindly help BECAUSE If I can not create a new page WHAT next is to be expected
Hi Bertrand! you r also requested for the replies to the above questions.

Thank u in anticipation,

The Newbie
Coordinator
Oct 6, 2013 at 6:14 AM
  1. enable the content wrapper and widget wrapper features
  2. doesn't sound like a question
  3. I don't understand what "the hierarchial subtlties involved in __item-type-part-field __ - - - - - defied the fixing (Which is which i.e. whether "Show on the Main Menu" is part or field)" means
Oct 6, 2013 at 5:36 PM
Thank you,

When creating a new page, I meant to seek clarity about the following:

IF:
  1. Page is content Item.
  2. Home page is Content type
  3. "Show on the Main Menu" is content part or content field
  4. What can be here if not a content field?
  5. If content field is at no.4 above, what must be at no.3 above?
I want some REAL WORLD examples for the sake of clarity!

Thank u in anticipation,

The newbie
Coordinator
Oct 7, 2013 at 7:02 AM
What does this mean: "home page is content type"?

"Show on a menu" is exposed by the Menu part. Check that your content type has that part.
Oct 9, 2013 at 3:07 PM
Thank u, I have noted your instruction.

I was working on Orchard.1.5.1 in Windows7, VS-12. Development server was responding properly. BUT meanwhile following scenaro has resulted and development is hindered i.e. website is not loaded. Instead following is given again and again:

Directory Listing -- /OrchardLocal/

 Sunday, October 06, 2013 07:17 AM        <dir> App_Data
 Sunday, October 06, 2013 07:05 AM        <dir> bin
 Sunday, October 06, 2013 06:51 AM        <dir> Config
 Sunday, October 06, 2013 07:01 AM        <dir> Core
 Wednesday, July 18, 2012 10:51 AM          103 Global.asax
 Wednesday, July 18, 2012 10:51 AM        2,124 Global.asax.cs
 Sunday, October 06, 2013 07:17 AM        <dir> Media
Wednesday, October 09, 2013 03:56 AM <dir> Modules
 Sunday, October 06, 2013 07:01 AM        <dir> obj
 Sunday, October 06, 2013 07:01 AM       12,828 Orchard.Web.csproj
 Sunday, October 06, 2013 06:52 AM        <dir> Properties
 Wednesday, July 18, 2012 10:51 AM          442 Refresh.html
 Sunday, October 06, 2013 07:01 AM        <dir> Themes
 Wednesday, July 18, 2012 10:51 AM        8,960 Web.config

Version Information: ASP.NET Development Server 11.0.0.0

Kindly guide on the above problem.

Thanking in anticipation.

The Newbie
Coordinator
Oct 12, 2013 at 11:12 PM
Anything in App_data\logs? Does it build?
Oct 24, 2013 at 2:11 PM
Thank u for continued help!

Sub: Two Strange Observations.

(I) First Observation
Now when working ( with 3 latest releases of Orchard) on Windows 8, VS2013, Orchard is not loaded and the following is observed:
  1. For Orchard.Soruce.1.5.1: Process with an id of 1352 is not running.
  2. For Orchard.Soruce.1.6.1: Process with an id of 6032 is not running.
  3. For Orchard.Soruce.1.7.1: Process with an id of 2532 is not running.
(II) 2nd Observation
When working on Windows 8, VS2012, Orchard is loaded in the case of 1.5.1 & 1.5.6 releases by Visual Studio Development Server but in the case of 1.7.1 release VS Development Server do not respond.

PS: I have not yet succeeded in fixing iis, BUT task bar sometimes shows an icon of iis when working on vs 2013.

Thanking you in anticipation,

The Newbie