Designer tools not working in 1.7

Topics: General
Sep 13, 2013 at 10:34 PM
Edited Sep 13, 2013 at 10:48 PM
Hello:

I'm trying to enable the Designer Tools module in Orchar 1.7 but I'm getting this error:

Image

Text: The assembly reference 'ClaySharp' could not be loaded for module 'Orchard.DesignerTools'.

Am I missing something?

Thanks!
Developer
Sep 13, 2013 at 10:43 PM
Orchard 1.7 dose not have Claysharp. I have a feeling your upgrade has gone wrong, or you are trying to install an earlier version of that module.
Sep 13, 2013 at 10:56 PM
Jetski5822 wrote:
Orchard 1.7 dose not have Claysharp. I have a feeling your upgrade has gone wrong, or you are trying to install an earlier version of that module.
Which upgrade could have gone wrong? I just started a new project and tried to install designer tools.

How can I solve the problem? Where should I look to repair something?
Coordinator
Sep 14, 2013 at 12:01 AM
I'm not sure what you're talking about: you don't need to install anything, as the DesignerTools module comes with the standard Orchard packages.

Delete the module's folder and replace it with the one from the source or runtime package.
Sep 16, 2013 at 4:27 PM
Edited Sep 16, 2013 at 4:30 PM
So yeah... I realized that in Orchard 1.7 Designer Tools come installed from default and the features are divided as: Shape tracing, Url alternates, Widget alternates.
I was able to delete the 1.6 old module I installed from gallery (by deleting the folder), recompile the module from the orchard sourcecode, replace the module in my Orchard site and enable the Shape tracing.

Thanks! =)

This thread also helped me to find out what I was doing wrong: https://orchard.codeplex.com/discussions/451910

I posted this without getting to read Bertrand post, thanks anyway.

PS: The problem here is the documentation because it is full of deprecated explanations; sorry about asking silly questions but that's what happens with noobs like me. I will take some time in the future days to contribute to the documentations.