i find a bug about Taxonomies and Navigation

Topics: Core, Writing themes, 中文(Chinese)
Aug 21, 2013 at 2:39 PM
Edited Aug 21, 2013 at 2:54 PM
i test the applaction with orchard 1.7.
i set the Taxonomies as these:
 a
  a-1
    a-1-1
      a-1-1-1
    a-1-2
  a-2
    a-2-1
    a-2-2
b
  b-1
  b-2
  b-3
    b-3-1
    b-3-2
    b-3-4
  b-4 
but in frontend the main menu's HTML list as these:
<nav>
    <ul class="menu menu-main-menu">
        
        
<li class="current first">
    <a href="/">Home</a> 
</li>
<li>
<a href="/Contents/Item/Display/39">Test Projection</a>
</li>
<li class="dropdown">
<a href="/truck/type-a">a</a>
                <ul>
                    
<li class="dropdown">
<a href="/truck/type-a/series-a">a-1</a>
                <ul>
                    
<li class="dropdown">
<a href="/truck/type-a/series-a/model-a">a-1-1</a>
                <ul>
                    
<li>
<a href="/truck/type-a/series-a/model-a/2913">a-1-1-1</a>
</li>
                </ul>
</li>
<li>
<a href="/truck/type-a/series-a/a-1-2">a-1-2</a>
</li>
<li>
<a href="/truck/type-a/series-b/model-b">a-2-1</a>
</li>
<li>
<a href="/truck/type-a/series-b/a-2-2">a-2-2</a>
</li>
<li>
<a href="/truck/type-b/b-3/b-3-1">b-3-1</a>
</li>
<li>
<a href="/truck/type-b/b-3/b-3-2">b-3-2</a>
</li>
<li>
<a href="/truck/type-b/b-3/b-3-4">b-3-4</a>
</li>
                </ul>
</li>
<li>
<a href="/truck/type-a/series-b">a-2</a>
</li>
<li>
<a href="/truck/type-b/b-1">b-1</a>
</li>
<li>
<a href="/truck/type-b/b-2">b-2</a>
</li>
<li>
<a href="/truck/type-b/b-3">b-3</a>
</li>
<li>
<a href="/truck/type-b/b-4">b-4</a>
</li>
                </ul>
</li>
<li>
<a href="/truck/type-b">b</a>
</li>
<li class="last">
<a href="/blog">博客</a>
</li>
    </ul>
</nav>
these HTML are wrong! Do you find this bug?
Aug 21, 2013 at 4:43 PM
This bug is already identified see:

https://orchard.codeplex.com/workitem/19990
Aug 23, 2013 at 3:50 PM
Thank u very much