Recipe error

Topics: Customizing Orchard, Installing Orchard
Jun 28, 2013 at 7:38 AM
Edited Jun 28, 2013 at 7:56 AM
Morning all,

I have tried to create a custom recipe on 1.7 using the documentation but when "cooking the recipe" I just get back a 404 error:

The resource could not be found.
Requested URL: /


Also, I cannot access any pages after the create eg: "/admin"

Here's what my recipe looks like...
<?xml version="1.0"?>
<Orchard>
  <Recipe>
    <Name>MyRecipe</Name>
    <Description>My custom recipe</Description>
    <Author>Me</Author>
    <WebSite>http://orchardproject.net</WebSite>
    <Tags></Tags>
    <Version>1.0</Version>
  </Recipe>
  <Module packageId="Orchard.Module.Bing.Maps" />
  <Feature enable="Orchard.Blogs,Orchard.Comments,Orchard.Tags,Orchard.Alias,Orchard.Autoroute,
                   TinyMce,Orchard.MediaLibrary,Orchard.ContentPicker,Orchard.PublishLater,                   Orchard.jQuery,Orchard.Widgets,Orchard.Widgets.PageLayerHinting,Orchard.ContentTypes,
                   Orchard.Scripting,Orchard.Scripting.Lightweight,
                   PackagingServices,Orchard.Packaging,Orchard.Warmup,Orchard.Projections,Orchard.Fields,
                   TheThemeMachine,Bing.Maps" />
  <Metadata>
    <Types>
      <Page ContentTypeSettings.Draftable="True" TypeIndexing.Indexes="Search">
        <TagsPart />
        <LocalizationPart />
        <TitlePart/>
        <AutoroutePart />
      </Page>
      <BlogPost ContentTypeSettings.Draftable="True" TypeIndexing.Indexes="Search">
        <CommentsPart />
        <TagsPart />
        <LocalizationPart />
        <TitlePart/>
        <AutoroutePart />
      </BlogPost>
    </Types>
    <Parts>
      <BodyPart BodyPartSettings.FlavorDefault="html" />
    </Parts>
  </Metadata>
  <Settings />
  <Migration features="*" />
  <Command>
    layer create Default /LayerRule:"true" /Description:"The widgets in this layer are displayed on all pages"
    layer create Authenticated /LayerRule:"authenticated" /Description:"The widgets in this layer are displayed when the user is authenticated"
    layer create Anonymous /LayerRule:"not authenticated" /Description:"The widgets in this layer are displayed when the user is anonymous"
    layer create Disabled /LayerRule:"false" /Description:"The widgets in this layer are never displayed"
    layer create TheHomepage /LayerRule:"url '~/'" /Description:"The widgets in this layer are displayed on the home page"
    layer create Maps /LayerRule:"url '~/Maps'"
    widget create HtmlWidget /Title:"First Leader Aside" /Zone:"TripelFirst" /Position:"5" /Layer:"TheHomepage" /Identity:"SetupHtmlWidget1" /UseLoremIpsumText:true
    widget create HtmlWidget /Title:"Second Leader Aside" /Zone:"TripelSecond" /Position:"5" /Layer:"TheHomepage" /Identity:"SetupHtmlWidget2" /UseLoremIpsumText:true
    widget create HtmlWidget /Title:"Third Leader Aside" /Zone:"TripelThird" /Position:"5" /Layer:"TheHomepage" /Identity:"SetupHtmlWidget3" /UseLoremIpsumText:true
    site setting set baseurl
    menu create /MenuName:"Main Menu"
    page create /Slug:"welcome-to-orchard" /Title:"Welcome to Orchard!" /Path:"welcome-to-orchard" /Homepage:true /Publish:true /UseWelcomeText:true /MenuText:"Home" /MenuName:"Main Menu"
    page create /Slug:"maps" /Title:"Bing Maps" /Path:"Maps" /Homepage:false /Publish:true /UseWelcomeText:false /MenuText:"Maps" /MenuName:"Main Menu"
    widget create MenuWidget /Title:"Main Menu" /RenderTitle:false /Zone:"Navigation" /Position:"1" /Layer:"Default" /Identity:"MenuWidget1" /MenuName:"Main Menu"
    theme activate "The Theme Machine"
  </Command>
</Orchard>
Developer
Jun 30, 2013 at 1:03 AM
Did you check the log files? Might expose interesting errors that occurred while executing the recipe.
Jul 1, 2013 at 7:10 AM
Thanks sfmskywalker, I managed to sort this out over the weekend. I used a fresh copy of orchard, possible the copy I was using had a corrupted file or something similar.
Jul 2, 2013 at 8:42 AM
I see this a lot when the package can't be downloaded from the Orchard gallery. A bug already filed on it.