This project is read-only.

Shape tracing issues

Topics: Customizing Orchard, General
May 2, 2013 at 12:10 PM
Hi there

I am using the Shape tracing tool. I have 2 issues with this.
  1. The icon to open the tool does not always appear in the bottom right hand corner, it sometimes takes a few minutes and seems to work when I switch windows and refresh. Any ideas? Is there a shortcut key to open it?
  2. I want to use the 'Create' url alternates function but when I click 'Create' after a while I get a Server 500 error. Any ideas please?
Many thanks,
May 2, 2013 at 2:00 PM
  1. See this issue. Hitting Ctrl+F5 usually solves the issue.
  2. Probably the web application's app pool doesn't have write permission to your theme's Views folder. But don't be discouraged, just create the file yourself with the name indicated by Shape Tracer if nothing else works.
May 7, 2013 at 9:42 AM
Thanks for your reply. I have tried Chrome and hitting Ctrl + F5 at the same time but neither seem to help.
I can't get it to open at all this morning!
May 7, 2013 at 4:01 PM
Edited May 7, 2013 at 4:11 PM
I run into the Tracing Tool not showing up every now and then too. It's usually there but the browsers some times don't draw it(?) when it should. I've found that (I use Chrome) when I press F12 to show/hide the inspector the Tracing Tool will show up.

As far as the 500 error I'm not sure what to tell you. Maybe look into the log files for a clue? Do you have the machine key set. Or maybe check that the server isn't running out of memory? I'm just lobbing some ideas out.