Internet Explorer 10 + Sign in

Topics: Core, Troubleshooting
Apr 28, 2013 at 1:47 PM
I'm having a strange bug with Internet Explorer 10 and orchard.
Using orchard 1.6, Internet Explorer 10, Windows 8 Professional.
(I have this on several different PC's).

I've attached a picture to demonstrate the problem:
https://skydrive.live.com/#cid=CB15F1A932B364BE&id=CB15F1A932B364BE%216716

1) I try to sign in by clicking the 'Sign In' link.
2) I enter my account and click 'Sign In'
3) Normally I should be logged in by now but I'm not logged in because I still see the 'Sign In' at the bottom.
4) But when I turn on compatibility view in IE10, the page refreshes and shows me the 'Sign Out' url.

I cannot log in to orchard by using Internet Explorer 10 by default, I have to turn on compatibility view.
Because I have this on different pc's it looks like a bug to me. I hope anyone could help me with this.
(nothing in my cache, I cleared it already, etc...)
Coordinator
Apr 29, 2013 at 12:25 AM
Do you have a machine key defined?
Apr 29, 2013 at 7:28 PM
I don't think I clearly understand what you mean by this.
Where should I look to know this?
Coordinator
Apr 29, 2013 at 7:33 PM
Jul 11, 2013 at 4:13 PM
I still have the problem after setting up the machine key following the instructions.

Chrome and FF work fine without any issues.
Jul 11, 2013 at 5:27 PM
Reason could be you site is seen as in the Internet zone by IE10, or your home page is cached, try changing either parameter.
Jul 11, 2013 at 10:50 PM
Thanks a lot for the tip.

I deleted all temporary data, but the problem remained. However, after I added the site to the trusted sites list, it worked instantly.

Could you point me to a source that explains in a bit more details about this unique requirement by IE for Orchard?
Coordinator
Jul 12, 2013 at 1:21 AM
Edited Jul 12, 2013 at 1:28 AM
You should not have to put the site in trusted sites, and it should just work in IE 10. Can anybody else reproduce this?

FWIW, I tried to repro, and I can login fine with IE 10, on two different sites. Something has got to be different on your machine. Did you try to reproduce from a different computer?
Jul 12, 2013 at 2:01 AM
Edited Jul 12, 2013 at 2:02 AM
Yes, I think you are right. It probably has something to do with my machine. Unfortunately, I have only one machine running Windows 8 Pro. I cannot reproduce this on my Windows 7 machine.

This started to happen recently. I do not remember exactly when, but I would say within the past week or so.

I removed the site from trusted sites, cleared cache, restarted IE, and the problem came back. Then, I added the site back to trusted sites, then clicked "Sign in", and I got in immediately without going through the log-in screen.

Anyway, this is not a big deal for me at all. I am content.
Coordinator
Jul 12, 2013 at 2:10 AM
Maybe you have a weird configuration that doesn't allow cookies on the internet zone or something along those lines?
Jul 12, 2013 at 2:57 AM
I have reset all zones to default level, but the issue remains if I have taken the site out of trusted sites.

Actually I only need to refresh a page to log in after I add the site to trusted sites (i.e. I do not even need to click sign in).,
Coordinator
Jul 12, 2013 at 3:00 AM
Wowowow. Do you have impersonation on on this IIS application?
Jul 12, 2013 at 3:14 AM
No. The site works normally with FF, Chrome on the same machine, IE10 on a Windows 7 machine, and IE10 on Windows Server 2008R2.
Coordinator
Jul 12, 2013 at 4:44 AM
That's not what I'm asking.

Other question: can you reproduce with a vanilla Orchard running on the VS development server?
Jul 12, 2013 at 5:29 AM
Edited Jul 12, 2013 at 5:38 AM
I have same behavior with w8 and ie10...(but need to click signon) ...I don't get time to understand why...the login is effective but the return page has been cached and don't reflect the menu change...I was more thinking of one more IE pb on W8 than an orchard pb....
Coordinator
Jul 12, 2013 at 5:50 AM
Do you have similar issues with other non-Orchard sites? And is it the Metro IE or the desktop one?
Jul 12, 2013 at 6:31 AM
Edited Jul 12, 2013 at 7:25 AM
I just gave this tip, having no more time to investigate it.
Certainly something in my config related to W8 settings and may be my code (but very classic for login only new theme with new templates in theme folder)
It appears on one of my Orchard site, no on all. I never deeply searched the reason.
I have not checked for some other 'web thing' as Orchard.

Problem is W8/IE10 which have special login features, the first being to try to connect you to 'MS internet' with you local account.
Having already plenty problems with all the automatic login feature of w8 and the various Microsoft sites (partner, O365, CRM Online, Bizspark, old ones), as my W8 has a personnal login, the partner & related site know my previous company's login for France and my actual company when going US login page (!!! crazy no way to change already opened plenty tickets) , the O365 is on the onmicrosoft.com generated login (but receive from time to time notification from old instances on my backup email), the bizspark site my new company login, in the Azure AD I have also the ADFS internal login of a previous company where I setup Microsoft ADFS connect with internal domain....
Certainly a cookies horror movie world and MS internal Dbs advanced indexing in guest star.
From time to time Windows 8 enters a foolish period with MS sites automatically login with a bad account, I never knows exactly where I am landing after login....

Back to this simple problem, this site has exactly same web config as the others, recently I have migrated it to framework 4.5, moving all my projects and it seems that the effect has disappeared :) or is it the recent VS2012 SP3 ?
Jul 12, 2013 at 1:27 PM
No impersonation. I stopped using impersonation long time ago.

My point is that if impersonation were used, would it affect FF, Chrome, IE10 on other Windows OS' too?
Coordinator
Jul 12, 2013 at 5:27 PM
I'm just trying to eliminate variables here. We don't have nearly enough information to figure out what's going on, and we can't repro ourselves so far.
Jul 12, 2013 at 7:57 PM
Edited Jul 12, 2013 at 7:57 PM
I am unable to reproduce anymore despite trying all kinds configurations (adding, removing the site from trusted sites, deleting cookies, etc.). The machine that hosts this low traffic site runs Windows 7 Ultimate. The following updates were installed today before I failed to reproduce it (the client Win 8 machine has not installed any updates today):
Image
Coordinator
Jul 13, 2013 at 9:04 AM
Looks like one of those .NET updates is fixing the problem.
Jul 13, 2013 at 10:33 AM
Ok, I'm almost back from holiday. Saw the emails but could not respond from that country.
I'll install recent updates on my win8 pro machine at home and also at work (monday) and will let you know if i still have the problems with all recent windows updates. (this means installing updates from the last 2 - 3 weeks)
Jul 13, 2013 at 10:57 AM
We're seeing something similar, only with IE, not with chrome:

Log in with IE10
Go to /Admin
Redirected to logon page
Enter correct credentials

Now we are logged on, we're redirected to /admin, but immediately redirected back to the logon page.

When we change to IE9 mode, we are already logged in and we can access the admin site directly.
Coordinator
Jul 13, 2013 at 10:03 PM
Erik: please check your machine key, and that you have the latest Windows updates.
Jul 14, 2013 at 2:02 PM
Haven't checked the machine key, but when I change the browser to IE9 mode (pressing F12 and selecting IE9) I can access the admin site directly)

A problem with the machine key would not allow me to use the IE9 compatibility mode.

Also I see a redirect(302) from the login page to the actual page, followed by a redirect(302) to the login page again. Tried also on Server 2012, and my Win8 with all updates. This could still be a server .NET problem, not sure if the server has all the updates.
Jul 14, 2013 at 7:55 PM
I've installed all updates on my home pc (win 8pro) now and I could log in directly.
I'll see tomorrow if this also fixes the problem on my other win8 pro machine.

these were the updates I've installed: https://skydrive.live.com/#cid=CB15F1A932B364BE&id=CB15F1A932B364BE%216837
Coordinator
Jul 15, 2013 at 1:02 AM
Erik: yes, it's the server that needs to have the updates, not the client.
Jul 24, 2013 at 8:21 PM
I thought the problem was gone, but it just happened again. I need to set the compatibility mode on in IE10 to get it working normally
Jul 24, 2013 at 8:33 PM
juFo, have you installed all the updates on the server?

Hong
Jul 25, 2013 at 10:05 PM
zipswich wrote:
juFo, have you installed all the updates on the server?

Hong
Yes, installed also some optional updates but now i have it 1/10 or 1/20 that it doesn't work correctly on one pc, and the other works good now.
it must be something with the windows updates on both server and client.

I'm Lucky that I control the server also, but for those who don't have access to the servers, they might experience problems if the server is not up to date...(same for the client story).