Missing Image Field Part when installing the Image Field Module

Topics: General
Mar 9, 2013 at 4:30 AM
Edited Mar 9, 2013 at 4:45 AM
Dear Community:

I've been having some troubles with the Image Field Module provided by Mr. Ros.

Please bare with me. I will enumerate the steps to repeat this behavior and I will state the technical settings of my environment.
  1. I proceed to login into the site's dashboard, providing the login credentials for the admin account.
  2. At the dashboard's side menu, I proceed to select "Modules" in order to install a new Module.
  3. I click on the "Gallery" tab on the content page.
  4. I click on the text field next to the "Search" button and type "Image". I press enter or click on the "Search" button to start looking for the Image Field module.
  5. If there is no problem with the Internet connection, I get a list of modules that matches my search criteria. In this case, I want to install "Image Field - Version: 1.1.3", which is the latest version up to this date, February 9th, 2013. To do so, I click on "Install" next to the description of this module.
  6. After a few seconds, depending on the performance of your infrastructure, the module is installed and, stating the path where it was installed and it will suggest if you want to enable the installed module. There is a checked check-box. Click on "Enable".
If there were no errors, you will have the Image Field module installed. You can also check that by browsing on your Orchard Installation. You will be able to find it in the Drive-where-you-installed-your-web:\your-orchard-installation\Orchard\Modules\Contrib.ImageField folder.

Now this is what I am trying to do in order to use the Image Field Module:
  1. At the Dashboard Admin Side Menu, select "Content".
  2. Select the "Content Types" tab in the "Manage Content" page.
  3. Modify the "Blog Post" content type by clicking on "Edit".
  4. Proceed to add a new part, in this case, the Image Field part that you had installed through the Image Field Module. To do so, go to the "Parts" section of the content type and click on "Add Parts" button.
Expected Result at this point:

I was expecting to see the "Image Field" part in the list of content parts that I could add to my Content Type, but, it doesn't appear here. I was able to reproduce this step in another installation (server, IIS installation, DB) but, for some reason, not in this server.

I also tried to confirm if the Image Field part was enumerated in the "Content Parts" tab in the same "Manage Content" page, but, it doesn't appear there, neither.

I confirmed if the Image Field Module is installed and to do so, I:
  • Clicked on "Modules" on the side menu of the Dashboard.
  • Clicked on the "Installed" tab of the "Modules" page.
I confirmed if the Image Field Module is enabled and to do so, I:
  • Clicked on the "Features" tab of the "Modules" page.
  • I browsed to the "Fields" section of the "Features" tab.
  • The Image Field Module is installed, and enabled. It states that it depends on the "jQuery" and "Media" modules, as well.
Steps to try to remedy this behavior:

I proceeded to restart the site, recycle the site, delete the site and reinstall it, including the DB, reboot the server (something critical since this is our production app server! ':( ) but all of this with no avail.

OS: Windows Server 2008 R2 E.E.
DB: SQL Server 2008 R2
.NET: All the way to 4, including MVC 4.

Any advice / hint / would be deeply appreciated.
Mar 9, 2013 at 8:11 AM
I think you need full trust for the ImageField.
Developer
Mar 9, 2013 at 9:17 AM
Use the MediaPicker in Orchard.Field and make an alternate in your theme to customize the rendering and display an img instead of a link.
Mar 9, 2013 at 12:14 PM
Edited Mar 9, 2013 at 12:14 PM
Hello planetClaire and agriffard.

Sébastien Ros already gave me an interesting hint. Thanks for your kind reply.
Coordinator
Mar 9, 2013 at 8:44 PM
But Antoine is right, you'd better use the default Media Picker Field.