This project is read-only.

Submenu trouble

Topics: Core, Customizing Orchard
Feb 27, 2013 at 12:16 PM
Hi guys,

I'm new to orchard, a designer not developer. I have set up a client website but can't get the submenus working at all. According to the docs (I'm using 1.6) I should be able to create a hierarchical menu by dragging a child under the top level link, except that it doesn't happen.

I'm guessing it's something simple, I've tried the answers in the documentation to no effect, clicked items on and off, tried it in different browsers etc, etc. I installed via Webmatrix.

If anyone could give me clue as to what I'm missing, it would be truly appreciated.
Feb 27, 2013 at 12:50 PM
Do you mean that you can't create the hierarchy from the admin by dragging menu items under a parent item? Does drag/drop not work? If it does, did you hit the "Save All" button?
Feb 27, 2013 at 1:15 PM
I can do the drag and drop, no problem and the save all button is hit every single time. I go back into the navigation and the hierarchy is there, it just doesn't work on the test site.
Feb 27, 2013 at 2:02 PM
Ok. Could you please explain what is not working? What would you expect to see on the test site, and what are you seeing instead?
Do you see any menu items at all? If not, did you add a MenuWidget?
Feb 27, 2013 at 2:28 PM
I created the menu widget, so I get the first level displayed in the navigation area as expected. I'm expecting the second level when I either click or roll over the button that has a child element.
Feb 27, 2013 at 2:29 PM
If you look at the HTML source of the rendered page, do you see the child items?
Feb 27, 2013 at 2:35 PM
Yep, they are there.
Feb 27, 2013 at 2:43 PM
So it's a theming issue. Are you using TheThemeMachine, or something else?
Feb 27, 2013 at 2:53 PM
Theme machine - I'm styling to spec via the stylesheet.
Feb 27, 2013 at 3:01 PM
I can't reproduce that issue. When I setup a clean 1.6 Orchard instance, create a menu hierarchy, add a Menu widget, it just works. Can you verify this with a clean install?
Feb 27, 2013 at 3:23 PM
I probably could, will do a backup first. Seeing as the child items in the source, I suspect it's a problem with the jquery show and hide. Thanks for your help, I'm a little bit closer to resolving the issue. :)
Mar 3, 2013 at 12:43 AM
There is no jQuery involved: it's all CSS.