Building Orchard Project

Topics: Administration, Core, Installing Orchard
Feb 20, 2013 at 4:51 PM
When i download the Source Code for Orchard Project, i build Using Visual Studios and it works fine, i create the user Recipe and all that... After making a few tweeks to the Theme changing Css an Html here and there all inside the theme folder, i stoped workingon the project for a few days and ithenm now when i go back to build the project and work on it again, when i Run the Project using ctrl+F5, it sends me to the "http://orchard.codeplex.com" Orchard Download Page... i'm confused... i cant seem to get it to run, the build shows:

"Build: 67 succeeded, 0 failed, 0 up-to-date, 0 skipped"
Developer
Feb 20, 2013 at 8:34 PM
Make sure that you run the Orchard.Web project / that it is the startup project (regardless of the selected project when hitting F5).
Feb 20, 2013 at 10:01 PM
So by saying "Orchard.Web Project", do you mean i need to run the "Orchard.Web.csproj"

sfmskywalker wrote:
Make sure that you run the Orchard.Web project
Coordinator
Feb 21, 2013 at 2:12 AM
Yes.
Feb 22, 2013 at 6:32 PM
Edited Feb 22, 2013 at 6:44 PM
still did the same thing, when i ran it using "Debug>Start Without Debugging" or ctrl+F5, it brought up "http://orchard.codeplex.com" the build output showed nothing...

Are you sure im not supposed to run "Orchard.sln" in the src folder?

Regardless, i tried to run both files and build in VS and both sent me to "http://orchard.codeplex.com"...
Feb 22, 2013 at 6:49 PM
Edited Feb 22, 2013 at 6:51 PM
one thing i forgot to mention, when i run the files, .sln or .csproj,; VS prompts me to with an queston...

"The solution you have opened is under source control but not currently
configured for integrated source control in Visual Studio. Would you
like to bind this solution to source control now?"

I always select no, because i don't want to change anything. Could this be one of the issues?

Sorry for my ignorance, im not a .net Developer, i am a Front-end UI Developer (Javascript/HTML/CSS)...
Feb 22, 2013 at 6:59 PM
I played around with it, and it turns out, that when it prompted me to bind the solution, i chose "yes" then ran (Ctrl+F5) it, and it worked... Hmmm... not sure if i can explain what Binding the solution did, but hey it worked, I'm not complaining.

Thanks anyway for helping!! :)
Feb 23, 2013 at 5:20 PM
I noticed this when I start new Orchard solutions after doing a fresh clone of the source. I solve it by (from Visual Studio) right clicking the Orchard.Web project in Solution Explorer, and selecting "set as startup project".