Custom Module Targeting .NET 4.5

Topics: Customizing Orchard
Jan 23, 2013 at 3:50 PM

Is .NET 4.5 supported for custom modules?

The developer FAQ says Orchard supports .NET 4.0, but I have seen posts referencing version 1.6's support for 4.5.

Do we need to make any changes to Orchard so that it will load a module targeting version 4.5? For example, changing the target framework on the orchard projects.

Feb 10, 2013 at 9:35 PM
Of course, yes. The target framework is not per module, it's per application. If your application pool is configured to run 4.5, everything in there will.