This project is read-only.

ClickToBuild not copying custom module Dlls

Topics: Customizing Orchard, Installing Orchard, Troubleshooting, Writing modules
Jan 19, 2013 at 2:09 AM

I have created two modules. When using clickToBuild to build my project, my module DLLs and cshtml files under Views are not getting copied and I am not seeing my modules when testing the site from the Stage folder. 

This is happening with both custom modules and some modules downloaded from the Orchard gallery. 

I have tried building from a VS command prompt as well with the same results.

How do I make sure all of my DLLs and views are being copied?


Jan 19, 2013 at 5:38 AM

Try to follow those instructions:

Jan 19, 2013 at 12:36 PM

I've gone through those steps and still don't see my modules. I'm wondering if there is something wrong with my csproj? This happens also on the Google Analytics module and Vandelay Industries tag cloud module, not just my created modules.

If I copy the DLLs and Views for each manually, the site will work.

Jan 19, 2013 at 11:44 PM

Did you add your module to the solution?

Jan 20, 2013 at 2:59 PM

Yes, that was the problem for the installed modules that were not working, so thank you for that advice. For my created modules, I followed a tutorial and created the project as a Class Library. I deleted those modules and re-created them as ASP.NET Web Applications and copied my code to the new project. That worked for my created modules.

Thank you for the help.