Changing page friendly url is not updated in menu

Topics: Administration, Troubleshooting
Jan 8, 2013 at 11:50 AM

Hi,

I tried to change the friendly url for a few pages and thats ok but when I go to website the menu items are still pointing to the old url, I also did ctrl+F5 with no success.

Orchard: 1.4 | Module: Advanced Menu

 

Thanks in advance

Jan 9, 2013 at 7:42 AM

To be more precise I went to Admin->Page->Content Items select an item, and change the Permalink. Upon saving and publishing, the menu was still pointing to the old url and not the new one.

Jan 11, 2013 at 7:18 AM

So is this a bug or when I update the friendly url for a page I need to do any other action in order to take effect???

Coordinator
Jan 11, 2013 at 5:06 PM

Please check whether you used custom menu items or content menu items.

Developer
Jan 11, 2013 at 11:06 PM
Edited Jan 11, 2013 at 11:06 PM

If I recall correctly, Piotr's Advanced Menu module does not work with custom nor content menu items. There are 2 types: a menu item, and a menu item with custom html. I guess both types are a sort of 'content menu item', since they maintain a reference to a content item.

It sounds like a bug, so I would file one on the Advanced Module's project site itself.

Jan 15, 2013 at 10:39 AM

Thanks, can you provide me the link to this bug so i can check its status?

Developer
Jan 15, 2013 at 12:38 PM

Sorry, it was a suggestion to you. Let me rephrase: If I were you, I would file a bug on the Advanced Module's project site itself.