Orchard Project Forum Module on display...

Topics: Announcements
Developer
Jan 2, 2013 at 6:35 PM
Edited Jan 2, 2013 at 6:35 PM

Hey Guys,

I have created a site that will be used to push out updated to my forum module for Orchard - also with a little marketing stuff etc.

http://orchardprojectforum.azurewebsites.net

You need to create a account through Orchard to post.

Have a play, lots to be done and as always, comments welcome.

Nick

Jan 3, 2013 at 9:02 AM

Nice work!

I've seen that the paging doesn't work correctly. Page 2 didn't show items but was accessible and visible.

Jan 3, 2013 at 1:39 PM

Finally !!!

Is it possible to download module, even if beta ?

Developer
Jan 4, 2013 at 2:05 PM

Sure you can download the module from the repo at http://orchardforums.codeplex.com 

Jan 15, 2013 at 5:48 AM

Hey Nick,

Sent you a tweet, but thought I would post in here as well.

I was able to load the module from the repo locally on my laptop running Orchard 1.6 using SQL CE. Everything loads fine when I compile and enable the module.

So...I installed Taxonomies and Voting on my hosted site running Orchard 1.6 using SQL Server 2008. I uploaded the compiled Forums module and attempted to enable it. I get absolutely nothing. I checked the database and there are NO tables being created, so I'm assuming the migration didn't run. I cleared everything out...Dependencies folder, mappings file, restarted the app pool...still nothing.

Have you been able to get it working on SQL Server? Is there a step I seem to be missing somewhere?

Thanks for any help you can provide.

Developer
May 30, 2013 at 10:09 AM
Hey All, the demo site is backup and running after getting some time to take a look.

http://orchardprojectforum.azurewebsites.net/

A few new things:
  1. Sign in with Google - will auto create your account for you
  2. Quick reply now shows up when you hit reply rather than always being present.
  3. In-line editing in Markdown is now present, you can edit your posts within the context of the current page - give it a go, its quick neat!
  4. A bunch of bug fixes and CSS changes - too many to note.
As always would love feedback.

Nick
May 31, 2013 at 7:48 AM
Great work Nick.

The inline editing works very well in Chrome and Firefox but not in ie9. The icon appears when you hover over the text but clicking on it does nothing.
May 31, 2013 at 10:39 AM
Edited May 31, 2013 at 10:44 AM
That IE bug is caused by calling console.debug in Orchard.InlineEditing/scripts/orchard-inlineedit.ui.js. IE's console object doesn't have a method called debug, so the script stops with an error.
More interestingly is this:
SCRIPT5007: Unable to get property 'offsetWidth' of undefined or null reference
jquery.textarearesizer.min.js, line 1 character 912
It’s harder to track down since the source is minified. It happens when loading a thread (e.g. http://orchardprojectforum.azurewebsites.net/sandbox/testing-of-email) in IE10.


BTW: I really like the inline editing and OT stuff.
May 31, 2013 at 11:13 AM
With regard to the ie9 bug: Console.debug has been deprecated; console.log should be used instead.

Worked for me.
Developer
May 31, 2013 at 11:34 AM
Thanks All, Fixed the console.debug -> console.log move. I can see the text resize issue, I just haven't got around to fixing it yet.

I just pushed a new update that changes the UI a bit.
  1. Heads are now have a border radius on them making them round.
  2. Metadata is top of the post and top border removed in favour of a border around the post's content.
  3. infinite scroll working on the Forum page.
Let me know what you think. N
May 31, 2013 at 12:38 PM
The reply with quote does not appear to be including the quote in the reply.
Developer
Jun 3, 2013 at 7:59 PM
Should all be working now, I had to rewrite the CSS for the markdown editor from scratch. I will need to change a couple things when I re-introduce grippie and also a few other things.

Going to look at drag and drop media next!
Jun 4, 2013 at 10:29 AM
Hi, Nick, A question here: which of the following two web sites is the offical site of NGM.Forum module?
1, http://orchardforums.codeplex.com/
2, https://github.com/Jetski5822/orchardprojectforum
Developer
Jun 4, 2013 at 2:12 PM
Hi StoneFeng.

1: That's the official Module.

2: That's the site that you can view http://orchardprojectforum.azurewebsites.net - Its basically Orchard 1.x + Orchard Forum Module (No #1) + a few other modules. Its basically there if you want to get a site with a forum up and running quickly. I will push a bunch of those to Git Sub Repos, also Orchard Forums Module (No #1) will be moving to GitHub soon.

Nick