Problème de publication

Topics: Francais (French)
Dec 22, 2012 at 1:47 AM

Bonjour,

Pour commencer j'ai un doute sur l'endroit où déposer mon message. Est-ce que le dossier FRANCAIS concerne les utilisateurs et questions en français ou juste toutes les traductions FR...

Veuillez m'excuser si je ne suis pas au bon endroit.

Je suis nouiveau sur Orchard et j'ai récupéré les sources que j'ai publié (Orchard.web) avec VS 2010.

Lorsque je lance l'appli en local pour tester, tout fonctionne bien à part les modules et les thèmes. Impossible d'en installer. J'ai un message d'erreur à propos de droits en écriture sur les dossiers modules et thèmes mais j'ai mis tous les droits sur tous les dossiers et j'ai toujours cette erreur.

Merci d'avance pour votre réponse

Developer
Dec 22, 2012 at 1:01 PM

Mettre les droits d'écriture pour l'utilisateur IIS_IUSRS sur ces dossiers devrait être suffisant :

  • Modules
  • Themes
  • AppData 
  • Media 

http://docs.orchardproject.fr/Documentation/fr/Installer-manuellement-Orchard-fichier-zip#ExécuterlesiteenutilisantIIS

Dec 22, 2012 at 11:52 PM

Bonjour,

Je l'ai fait mais toujours rien. J'ai mis tous les droits pour Tout le monde sur tout mon dossier pour "évacuer" les problèmes de droit masi rien n'y fait, je ne peux ni installer de modules ou de thèmes

Merci d'avance si vous avez déjà rencontré ce problème

Dec 29, 2012 at 3:23 AM

Si vous utilisez IIS localement sur votre PC cela devrait faire.

Vous pouvez également ajouter l'utilisateur IIS AppPool\NomAppPool sur le dossier racine de votre site web et ajouter en écriture sur les dossier mentionnés par Agriffard. Si vous utilisez le site par défaut de IIS le NomAppPool devrait être DefaultAppPool.

Sinon, si vous utilisez le pseudo-serveur intégré au déboggeur de Visual Studio 2010 ; ouvrir Visual Studio 2010 en mode administrateur serait peut-être aussi une idée qui pourrait fonctionner.

Jan 29, 2013 at 10:16 AM

Bonjour,

Pour info voilà où était mon problème. J'ai dupliqué manuellement un thème et dans le fichier Theme.txt, au niveau du n° de version, j'avais mis 1 au lieu de 1.0.

A cause de ça, je ne pouvais installer ni thème, ni module. Une fois corrigé, tout est ok