This project is read-only.

Error executing codegen command.

Topics: General, Installing Orchard
Dec 18, 2012 at 10:58 AM

I am trying use codegen module abcd

its showing error executing command.

when i typed help codegen, its showing Command codegen doesn't exist.

Orchard.CodeGeneration is installed and enabled.

Then why is this coming.

Plzz help me


Dec 18, 2012 at 11:38 AM

So you completed the setup of Orchard, went into the dashboard and enabled CodeGeneration? Strange, it should work. Perhaps try again with a clean install? Are you using the source package or web package?

Dec 18, 2012 at 6:00 PM
Edited Dec 18, 2012 at 6:09 PM

I am sure, I used the web package. I could not understand why codegen is not working. I tried the same on my personal system it worked though.

Dec 18, 2012 at 6:13 PM

Shall I install it using web platform installer and then set it to use my local IIS??

Dec 18, 2012 at 6:14 PM

Then I'm sorry, I have no idea why it wouldn't work. On which system are you trying it if not your personal system?

Dec 18, 2012 at 6:53 PM
Edited Dec 18, 2012 at 6:54 PM

If you're about to develop your own module, I would download the Source package or clone the source from Codeplex. Then build the solution using one of the batch files that come with the source package, or open the Orchard.sln with Visual Studio, and build and run the solution. Once the site is setup, go into the dashboard, enable CodeGeneration, and launch Orchard.exe from the Bin folder. Now I would dare the Codegen command try and fail ;)

Dec 18, 2012 at 9:58 PM

Could it be this bug: ?

Dec 19, 2012 at 7:13 AM

Thanks a lot guys. bertrandleroy it's the same bug. I tried using .Net framework 4.5 and now codegen is working.