update 1.3 to 1.6

Topics: Administration, Installing Orchard, Troubleshooting
Nov 24, 2012 at 2:00 AM

I'm trying to upgrade 1.3 to 1.6 and having troubles.  I made an entire copy of my site, backup / restore the database to a new database.  The site works.  When I delete the /bin and App_Data/Dependencies then copy the 1.6 code, I get all kinds of wierd things.  Do I need to update to a older version first before going from 1.3 to 1.6?

Nov 24, 2012 at 2:15 AM

I was getting an error on Orchards.Lists module, so I deleted.  I still get but nothing else shows up in the logs file. 

Server Error in '/' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

Requested URL: /


Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272

Nov 24, 2012 at 2:45 AM

Well, I had to type new.site.com/admin, then do an upgrade.  I had to delete the Orchard.Lists module, delete the dependencies and seemly the other stuff under app_data.   I had to the RSS module Bernard did, not a real straight forward upgrade path. :)  but seemly I have to remove / re-add things to get it to work.  

Nov 24, 2012 at 2:51 AM

Yes dear

upgrade roadmap 1.3 to 1.4 to 1.5 or 1.6

Nov 24, 2012 at 3:27 AM

http://orchard.codeplex.com/discussions/400181

Nov 24, 2012 at 4:58 AM

Well that stinks having to run one upgrade to another. :(  I see there are three 1.4 releases, do I need to run the minor or can I run the 1.4.2 to include 1.4 and 1.4.1

Nov 24, 2012 at 5:02 AM

Run Orchard CMS V1.4

Nov 24, 2012 at 5:04 AM
steveschofield wrote:

Well that stinks having to run one upgrade to another. :(  I see there are three 1.4 releases, do I need to run the minor or can I run the 1.4.2 to include 1.4 and 1.4.1


First run V1.4 and then go for V1.6

Nov 24, 2012 at 6:00 AM

Still having the problem with the contact page loosing fields after upgrading to 1.6.   I use the .94 CyberStrides module for creating forms (I think). 

Nov 24, 2012 at 6:21 AM

Looks like there might be an issue with 1.6.  Something was posted on 11/21 about this on the vendors site. I'll start the upgrade over again and go to at least 1.51

Nov 24, 2012 at 6:30 AM
steveschofield wrote:

Looks like there might be an issue with 1.6.  Something was posted on 11/21 about this on the vendors site. I'll start the upgrade over again and go to at least 1.51


Yes I can see that http://gallery.orchardproject.net/List/Modules/Orchard.Module.CyberStride.Contacts

Why not use Custom Forms for Contact Form - http://devdirective.com/post/160/how-to-create-custom-forms-in-orchard-cms-with-email-and-recaptcha