This project is read-only.

DesignerTools Module not working

Topics: Troubleshooting, Writing modules, Writing themes
Nov 21, 2012 at 9:15 PM

I put my orchard website on azure and have a local copy for development work before publishing the changes to azure. Last weekend it worked fine I come back and want to work on it more this week and I notice that my home page theme is not working. I made a alternate theme for my homepage through the Layout-url-homepage.cshtml file it was working fine before but now it is not. I downloaded the designerTools module and enabled alt urls. I think the module stopped working because when I enable shape tracer it no longer has the icon at the bottom of the screen to activate shape tracer. That to was working last week. So this tells me that the module is probably not working. I'm confused as to why the module suddenly stopped working, and not really sure how to go about debugging the situation so I would appreciate any help that anyone could provide me because I have tried everything I can think of. Thanks

Nov 22, 2012 at 8:04 PM

Does it work on your local copy of the site? Do you see anything in logs?

Nov 27, 2012 at 2:57 PM

It does not work on both the local copy of the site and the windows azure version of the site. I've looked in the logs and see nothing at all in regards to the designer tools module not loading correctly. If I go in the dashboard in both sites and look for that module it shows up in modules as enabled as well. Sorry it took so long to get back to you, I've been out of town over thanksgiving.

Nov 27, 2012 at 6:18 PM

Weird that you wouldn't get anything in logs. Are you sure you used the right version of the module, the one that corresponds to your version of Orchard?

Nov 27, 2012 at 9:09 PM

Yeah I'm running version 1.6 orchard and just checked and have designer tools version 1.6. In the logs I see nothing related to that module.

Nov 27, 2012 at 11:18 PM

In the absence of logs or exceptions, I'm not sure what I can advise. Maybe attach a debugger and put a breakpoint in the module?