Team Foundation Services (Preview) Build to Azure Websites (Preview) Missing Projects

Topics: General
Nov 19, 2012 at 1:16 AM

Hello,

I am not sure if this is the place to discuss but, since someone has fixed up Web Deploy (aside from a little Media folder issue) to work wonderfully with Azure Websites (Preview), I was wondering if the same technique could be done so that Team Foundation Services (Preview) - hosted on visualstudio.com - could build itself out properly to include ALL of the projects that are contained in the Orchard Solutions. Currently it will only build/publish Orchard.Core. This is the same issue that existed before the Web Deploy was fixed.  As it stands now, I can use the Team Foundation Services for source control but cannot directly connect it to Windows Azure and have it build the solution for me due to all the missing projects.

It would be FANTASTIC to see these tied off, call it a developers dream to not be using FTP. Unfortunately, I am not a smart enough developer in this are to know where to look. All thoughts, ideas, and recommendations are welcome. 

Nov 19, 2012 at 1:46 PM

I had misunderstood how Team Foundation Services works. Instead of pointing at the Orchard.Web project (which is typical in a Publish scenario) I had to point at the Solution file (Orchard.sln found in src folder).  However, now that this is resolved, I am encountering the following error:

C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\Web\Microsoft.Web.Publishing.targets (2352): Could not open Source file: Could not find a part of the path 'C:\a\src\Orchard\Trunk\src\Orchard.Web\Core\web.config;Core\web.config'.

"Trunk" is the name of the folder I am using in Team Foundation Service and the path does exist there so I am not sure why I am encountering this error.  The solutions builds perfectly in Visual Studio, just not in Team Foundation Services.

I am starting from a brand new project to ensure it is nothing I have changed and will post the update here. I may just have to post this on the Team Foundation Services forum: http://social.msdn.microsoft.com/Forums/en-US/TFService/threads and see if they have any ideas here as it looks to not be related to Orchard.

 

Nov 19, 2012 at 3:11 PM

Still a no go so I am not sure if this is an issue for Team Foundation Services or for Orchard. I have posted a request on Team Foundation Services: http://social.msdn.microsoft.com/Forums/en-US/TFService/thread/8f959964-c951-4f9a-8486-8283a925c9f6

I have updated to Rev 6680 also in hopes that the fix for webdeploy would take care of it and it doesn't take care of this particular issue.

In addition, I have taken a screenshot in hopes that it will help out with understanding the issue:

All of this information has been added into an issue: http://orchard.codeplex.com/workitem/19264

Feb 14, 2013 at 8:43 AM
To publish Orchard using TFS you can try this blog for a tutorial on how to publish.