Can't create Permalink with name of "Properties"

Topics: Administration, Customizing Orchard, General
Nov 14, 2012 at 10:30 PM

I am developing a real estate centered Orchard site (v1.6) running on IIS.  As this site deals with real estate properties, I am trying to create a projection page called "Properties" that lists all available homes with a Permalink of http://localhost/properties.  The page is created, however, when I try to access just this one page, it comes back with a 404 error.  However, one of my specific home pages at http://localhost/properties/test-property comes up just fine.  

After a few hours of frustration, I decided to bring up a brand new, clean build of Orchard 1.6 but this time I ran it under the Visual Studio Development Server.  I simply cooked the default recipe and created one single page (not a projection, just a normal page) called Properties with the default permalink.  When I accessed this page, it brought up a directory listing showing one file for AssemblyInfo.cs.  Therefore, I concluded that it's trying to access the special solution project folder.

How can I work around this?  As a real estate centered site, having a URL of properties is very standard.

Coordinator
Nov 16, 2012 at 9:37 PM

Aha, found it: http://stackoverflow.com/questions/987105/asp-net-mvc-routing-vs-reserved-filenames-in-windows

You need to do:

<configuration>
  <system.web>
    <httpRuntime relaxedUrlToFileSystemMapping="true"/>

    <!-- ... your other settings ... -->
  </system.web>
</configuration>

in your web.config file (in Orchard.Web)