This project is read-only.

Pretty Gallery gets 404 error on navigation buttons

Topics: Customizing Orchard, Troubleshooting, Writing themes
Nov 11, 2012 at 7:03 AM

I'm using Orchard 1.5.1 and have installed the PrettyGallery module. It works (sort of) except that the navigation buttons for PREV, NEXT and CLOSE are not showing up on the image except when I am in the dashboard editing the Pretty Gallery.

I discovered that I get a 404 error when the button images are being loaded. I use the IE Network capture tool in IE9 to see the requests. I see the following:

/Themes/RockinTheme151/images/prettyPhoto/dark_square/btnPrevious.png  GET   404   .....

and similar to above for the btnNext.png etc.

I looked at the css for prettyPhoto and it is referencing the buttons using the url - like this:

	div.dark_square .pp_next:hover { background: url(../images/prettyPhoto/dark_square/btnNext.png) center right  no-repeat; cursor: pointer; } /* Next button */
	div.dark_square .pp_previous:hover { background: url(../images/prettyPhoto/dark_square/btnPrevious.png) center left no-repeat; cursor: pointer; } /* Previous button */

I have my theme named Rockin151 in a folder under the Themes folder and it has a styles folder with a child folder named images with a child folder named prettyPhoto which contains the other theme folders for the prettyPhoto images.

Themes -> Rockin151 -> Styles -> images -> prettyPhoto -> dark_square

I installed the pretty gallery module and uploaded the photos. I've tried all of the themes and they all fail to let me see the navigation icons. If I go into edit mode and try to edit the gallery then if I click on one of the pictures in the gallery then it will have the controls on it. But it won't work out of the edit mode.

You can see what I mean if you go to and click on the race 2012 button. You will get a page full of thumbnails. If you click on any of the thumbnails it brings up the prettyPhoto but you will not see any  buttons.

I didn't know if the url(../images/prettyPhoto ......) in the prettyPhoto  had something to do with the problem or not. I figure that this must work but I'm using it all in what I think is the correct and stratight forward way.

I tried it using the ThemeMachine theme and it works - but I noticed that it loads the gallery files from a different place:


It seems like I must be missing something. I'm hoping it is something simple and that someone else has run into this problem and has a solution.