What version of .NET, MVC and Razor does Orchard CMS 1.6 use?

Topics: Installing Orchard
Nov 7, 2012 at 11:55 AM

I have had a brief look at the source code for Orchard 1.6.  In the web.config, there seems to be no mention of .net 4.5 or Razor 2.  And it shows the version of MVC as 3...

So does Orchard 1.6 use .NET 4 and Razor v1.0 and MVC 3?

Nov 7, 2012 at 4:59 PM

.NET 4.0, MVC 4 (including Razor 2) and Web API

Look at the binding redirections at the end of the file. This is just to ensure that old modules referencing MVC3 are actually using MVC4

Nov 7, 2012 at 10:35 PM

I have a coupole of external modules that I created with MVC 3 and are currently running in Orchard 1.5. If I want to use version 1.6 of Orchard will I be able to use my existing external modules? My plan would be to just start fresh with a new orchard 1.6 then attempt to add my existing modules.

Nov 7, 2012 at 11:11 PM

It should work. We didn't do anything specific for MVC4 in the already existing modules we had.

Dec 26, 2012 at 10:59 AM
Edited Dec 26, 2012 at 11:01 AM

Thanks, this helps me to :)