Mello.ImageGallery SliderViewerPro issue

Topics: General
Oct 24, 2012 at 7:04 AM
Edited Nov 19, 2012 at 4:02 PM

When using option "SliderViewerPro" I get below error:

Quote:
ALert: The thumbnail slider is too wide!
thumbsPercentRduction and/or buttosWidth need to be scaled
End quote

Where do I change these settings and what are the criterias to do so?

I experimented in:
Mello.ImagaGallery>Models>Plugins>SlideViewerPro> SlideViewerProSettings.cs
It changes the settings but it's still not working! Are there other places to change these values ?
Thanks for your time and hints
ed

PS: msg also sent to owner

Dec 4, 2012 at 3:32 PM

Hi,

Is this issue happening in all browsers? Try setting the image width and height in the gallery.

You may want to post this question in the Image Gallery site as well, someone may have a similar issue:  http://orchardimagegallery.codeplex.com/

Best Regards,

Gabriel Mello

Dec 4, 2012 at 4:15 PM

thanks for your time

it seems that I have the same issue in all browsers!

I might just not understand this SlideViewerPro option; I have defined:

the pictres are between 400-600 wide by 300-500 high

for the thumbnails 40*30 and get this errore msg:

Quote:
ALert: The thumbnail slider is too wide!
thumbsPercentReduction and/or buttosWidth need to be scaled
End quote

when changing the thmbnails to 400*300; no error; I see the photos running but somewhat overlapped!

Are there any rules how the pictures have to be set?
Shouldn't I be able to click a thumbnail and I see the original image - like with eg pretty view?
is there any doc?

thanks for your hints

ed

 

 



 

 

Feb 25, 2013 at 1:28 PM
after some time I found time to investigate this issue in more depth.
upfront: I loaded - from the Orchard Gallery - a new version of the 'mello.ImageGallery' and wonder whether
I miss something OR, whether this is an issue when using the 'SliderViewerPro' option !!! I only have the issue with this option!

What I observe is (! using the SliderViewerOption'):
  • when rendering the ImageGallery Widget the 'Height' and 'Width' of the image is taken from the thumbnail (as defined in 'Image Gallery Properties')!
    i.e.: I define the image size by the values of the 'Image Gallery Properties'
  • when using 'thumbsVis: true,' I get correctly the thumbnails - underneath the image - according to 'thumbsPercentReduction: 12,'
    i.e. 12% the size of the defined 'Height' / 'Width' from above!
  • this way all runs correctly: BUT that means, I never see the size of my original image! It is always the size of the 'thumbnail'!
But more annoying: when changing the option from 'SliderViewerPro' to 'Lightbox or PrettyPhoto' - correctly I assume -
the thumbnail is shown - which of course is, for this option, far to big! Then, clicking one of these 'thumbnails' the correct image (size) is rendered!

Of course knowing this I can live/deal with it BUT for an 'Editor' without too much know how it is NOT practical!

I might still do something wrong ... thanks for letting me know what!?

thank for your time and hints
ek
PS: I will forward the same msg to the Mello.ImageGallery project team!
Mar 17, 2013 at 10:09 PM
I'm having the exact same issue, were you able to resolve ?
Mar 18, 2013 at 5:10 PM
No its not solved and I never heard anything from the Mello project team. I didn't have time to further investigate. It seems that the scripts are taking the wrong values. As said I can live with it - and have some other priorities now!
good luck
ed
Mar 21, 2013 at 2:27 PM



From: [email removed]
To: [email removed]
Date: Mon, 18 Mar 2013 09:11:50 -0700
Subject: Re: Mello.ImageGallery SliderViewerPro issue [orchard:400561]

I was able to resolve my issue by setting the width and height to the gallery using the GUI.

From: edikaufmann
No its not solved and I never heard anything from the Mello project team. I didn't have time to further investigate. It seems that the scripts are taking the wrong values. As said I can live with it - and have some other priorities now!
good luck
ed
Read the full discussion online.
To add a post to this discussion, reply to this email (orchard@discussions.codeplex.com)
To start a new discussion for this project, email orchard@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com