Search returns zero results

Topics: Administration
Developer
Oct 11, 2012 at 9:04 PM
Edited Oct 11, 2012 at 9:05 PM

While working on the refactoring of the Comments module, we faced the following issue: after reimplementing some stuff about the display of comments, and successfully testing it with search results, search for comments started returning zero results after a while without touching any code or setting related to that (recloning/purging the repo didn't help). All of the code that is running now worked before, so we have to assume that something's broken in the indexing.
Comments are included in the index and the search field for the text of comment is searchable. After several rebuilding/restarting/index rebuilding/index deleting and rebuilding it still doesn't work. With some debugging we discovered the following: until line 347 of Lucene\Services\LuceneSearchBuilder.cs everything is going well, where we lose track of what's happening, because the method "Search" is in Lucene's DLL:

var hits = searcher.Search(query, Int16.MaxValue);

The parameter query contains the following value: eg. commentText:searchtext*

Anybody have any clue what may be wrong?