This project is read-only.

The OutputPath property is not set for project 'AzurePackage.proj'

Topics: General, Installing Orchard, Troubleshooting
Sep 23, 2012 at 5:55 PM

Hello - I've hit a big snag trying to deploy an Orchard site to Azure - I cannot build the Azure package using "ClickToBuildAzurePackage.cmd".

I have a source enlistment, default branch 1.5.1 (chngeset 6380)

It's the familiar error: 

c:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(483,9):error : The OutputPath property is not set for project 'AzurePackage.proj'.  Please check to make sure that you have specified a valid combination of Configuration and Platform for this project.  Configuration=''  Platform='Any CPU'.  You may be seeing this message because you are trying to build a project withouta solution file, and have specified a non-default Configuration or Platform that doesn't exist for this project. [C:\Shared\Projects\Personal\OrchardSites\Amethysts\AzurePackage.proj]

I get this trying to build for Azure on a straight-up enlistment and with my own solution, so it's not something I've done. Is there a known environment issue that could cause this? I'm on a Win7 box, 64 bit.

I have scoured the discussion board and google in general, no luck. I turn to the community as my last desperate hope!

Thanks guys - I'ma a big Orchard fan, I have 6 sites out in production now and I am super keen to get an Azure deployment under my belt.


Sep 23, 2012 at 6:02 PM

I should also mention: I have the Azure SDK version 1.7 installed, and I have tried changing 'Any CPU' to 'AnyCPU' in the csproj file, as well as Configuration=Release and Configuration=Debug. Nothing works unfortunately, and all combos give the same error.

Thanks again for any assistance. I'd hate to have to take a pass on Azure just because of some stupid configuration issue!

Sep 23, 2012 at 6:20 PM


Adding <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|Any CPU' "> on the first PropertyGroup section of the AzurePackage.csproj file provides a new error: can't import the project c:\msbuild\MSBuild.Community.Tasks.Targets - which is of course the wrong directory! It SHOULD be looking for "C:\Shared\Projects\Personal\OrchardSites\Amethysts\lib\msbuild" in this case. Does that provide a clue at all?

This project builds correctly for regular deployment (ClickToBuild.cmd), and is in fact deployed to a shared hosting service right now, no issues. It's just the Azure build that has me in fits.

I'll keep working on it and posting further details. I'm sure this is / has / will happen to someone else so best to document.


Sep 23, 2012 at 6:29 PM

OK, so you do have the SDK installed, but are you running the commend from the root of your clone, in a Visual Studio command prompt?

Sep 23, 2012 at 6:58 PM

Hi Bertrand - thanks for your time! Yes, I am - same procedure as a regular Orchard build, just the "ClickToBuildAzurePackage" instead of "ClickToBuild".

Like I said above, the build works fine for regular build - I just did it to confirm, and I've built this project several times before. I can also build both Orchard.Web and Orchard.Azure.Web from VS 2010 with no errors.

What do you think about the Targets directory issue I described?

Sep 23, 2012 at 7:13 PM

I don't know: I can build with no problem on a clone so there has to be something with the environment. So you did run the command from a *Visual Studio command line*?

Sep 23, 2012 at 9:37 PM

Yes, Visual Studio command line. I installed Azure Tools / SDK version 1.7 from Web Platform Installer.

Guess I'll just keep trying.  I'll post a fix if I find one.

Sep 23, 2012 at 9:44 PM

FYI: error screenshot(notice VS Command prompt ;-)

I get the exact same thing with a fresh clone ...

Sep 23, 2012 at 10:13 PM

Here's a screenshot of the tools I have installed (Azure-wise) .. perhaps I'm missing something, or I have the wrong version of something?

I feel totally helpless about this - I've yet to meet my match using Orchard (6+ sites now, lots of custom module work etc) but this has me licked. I'd love to get a site up on Azure as proof-of-concept for clients and colleagues. Hopefully somebody has had this same problem and will see this.

Thanks for any and all time and consideration - will keep documenting as I learn more ...

Sep 23, 2012 at 10:21 PM

More info - I tried to run the Orchard.Azure solution from VS locally, Release build (just Cntrl-F5 from VS) and got this error:

Could not load file or assembly 'msshrtmi' or one of its dependencies. An attempt was made to load a program with an incorrect format.

The dll is indeed in the 'bin' and 'bin\release' directories. I have "Orchard.Azure.Web" set as the startup project, and the configuration manager shows all project set to Build in Release mode.

Hope that helps.


Sep 23, 2012 at 11:42 PM

Actually I just ran it from a regular command line and it worked just fine. I'm sorry, I really don't see why it's not working for you. Did you try on other machines?

Sep 24, 2012 at 4:55 AM

OK - solution / workaround!

Using the command file "ClickToBuildAzure.cmd" just wasn't getting me anywhere, no matter what I tried. So, instead, I called msbuild directly from the enlistment root (where the command files are):

msbuild AzurePackage.proj /p:Configuration=Release /p:OutputPath=bin\Release

(Also in the .proj file I commented out <CallTarget Targets="Test" /> as this was erroring out with a well-known nunit exception).

Worked! The build runs, completes and creates the deployment package.

Whew - hope that saves someone a couple days' frustration. Pretty mysterious that it actually worked, so any explanations / insights / fixes would be great!