Content permissions - How do they work?

Topics: Administration, Announcements, Core, Customizing Orchard, Francais (French), General, Installing Orchard, Jobs, Localization, Troubleshooting, Writing modules, Writing themes, Русский (Russian), 中文(Chinese)
Aug 16, 2012 at 1:37 PM

What I would like to do is.. create a blog page that only authorized users can view.

I want anonymous users to not be able to view the website. I can configure that through "Access site front-end" disallow.

Then I want to give a user access to a specific part of the website. For example a blog I created. So I go to the blog settings, enable the "Content Permissions" part. Then I specify that the anonymous user has access. If I do it extremely (i.e. check ALL checkboxes), it still won't work. The user doesn't get any access.

When I view the "current permissions" (the disabled checkboxes), they always say the user doesn't have access.

What am I missing here? What do I need to do to get the disabled checkboxes checked, and what do I need to do to get the user to have read access to the blog? If I set "Access site front-end" to true, then the user has access to everything.

I don't understand this..

Aug 16, 2012 at 2:38 PM

I am having the same problem, i can't find any documentation about the new Content Permissions.

Aug 16, 2012 at 3:32 PM

Hi I am new to this but I did get Content permissions to work with pages and I just tried with securing a Blog and its does not work!

It does work on a blog post though!

There is a "list module" which i think could contain blog posts you could try using that instead of using a blog ... not an ideal solution I know


Aug 17, 2012 at 12:04 PM

Hey, yes, we've reproduced that. So we'll probably be making a patch that also makes the blog list / latest blog posts widget check the permissions.

Jan 19, 2013 at 12:51 PM

Any update on this? I am also trying to secure the blog on the front-end to only allow Authenticated users to view. Is there a patch yet?

Jan 19, 2013 at 10:18 PM

Did someone file a bug? If not, it needs to be done.

Feb 4, 2013 at 4:49 PM
Have problems with that module as well. If you deny global access for Anonymous role to all items, no matter how hard you try, you won't be able to grant a permission to access a specific page.
Feb 4, 2013 at 4:51 PM
Feb 5, 2013 at 11:16 AM
Thank you for filing bug.

I did find a relatively easy workaround by just doing the Blog as a Projection. It didn't take long to setup and then Content Permissions work. Admittedly, my Blog is pretty simple, so this might not work for everyone.