This project is read-only.

Order of Fields within Content Types

Topics: Customizing Orchard
Aug 9, 2012 at 8:36 PM

I am using the Lists module in orchard and I have created a content type to add an item to my list. I get it set the way I want and the fields are all in the correct order, also it appears correct in the Edit Content Type page, but the actual order of the fields is completely different when you go to the page to create the list item. Is there a way to make this work?

Aug 9, 2012 at 9:43 PM

So you are saying that when you edit a single item, the editor fields are in an unexpected order? If that's the case, then it's easy to fix using Admin based placement: go to Content - > Content Types -> Edit your content type -> press the "Edit placement" button you'll find to the top right.

Aug 9, 2012 at 9:57 PM
Edited Aug 9, 2012 at 10:05 PM

Hmm, I don't have "Edit Placement" anywhere on Edit Content Type on my page. Is it something you have to enable or install?

If you look at the screenshot my fields are in the correct order that I want to display in. When I go to the "Create Knowledgebase" (see below) the Manual Resolution field is appearing in the 2nd slot when it should come behind the others.

Aug 9, 2012 at 10:00 PM

I think it should be there by default in 1.5.1, not sure though.

Aug 9, 2012 at 10:40 PM

I was still running v.4.5. Just updated and it's there. Here I was thinking before I made this post, "Hey, there really should be a way to edit placement here."

Yet another million-dollar idea, down the drain!  Thanks for your help. ;)