Problem with ReSharper 7 and Orchard

Topics: Troubleshooting, Writing modules
Jul 30, 2012 at 4:36 PM

A razor view (cshtml) used @ the admin area for one of our modules worked OK when trying it with ReSharper 6 but now I'm trying ReSharper 7 and it throws a lot of "errors" @ the side.

Example: "Cannot resolve symbol 'Layout'"

Silly thing is that I CAN  'F12' on 'Layout' to go to the declaration.

Anyone else ran into the same issue with ReSharper 7?

Developer
Jul 30, 2012 at 4:55 PM

I'm about to install ReSharper 7 today, will let you know how it works for me.

Jul 30, 2012 at 8:05 PM
sfmskywalker wrote:

I'm about to install ReSharper 7 today, will let you know how it works for me.

And? :)

Developer
Jul 31, 2012 at 2:12 PM

No issues yet: no errors about the Layout symbol or anything like that. Perhaps a complete reinstall of Resharper may solve it? Also be sure to remove the .resharper files (not sure if that would make any difference though).

Jul 31, 2012 at 2:13 PM

I resolved it in the meanwhile, most of my modules didn't have the right project type guids.

Strange though, since all of them were generated using codegen. Is it possible that got 'changed' recently (as I checked and the templates do contain the correct project type guids)

Developer
Jul 31, 2012 at 3:07 PM

I don't know if that has changed, but good to know you figured it out and that it's not an issue with ReSharper 7 :)

Developer
Aug 4, 2012 at 1:16 AM
Edited Aug 4, 2012 at 1:27 AM

Hmmm... I just installed ReSharper 7 and there is a *load* of errors being shown everywhere (even in core modules) - classes/interfaces are marked as not-existient and so on. Tried reinstalling and it stays the same. Generally - total mess...

Any clues?

EDIT: Found out a solution. You need to delete the _Resharper.Orchard folder (containing old R# analysis cache) and all problems will go away.

Apr 5, 2013 at 1:10 PM
Hi, I'm also having errors from Resharper such as:
 Solution Orchard.sln
    Project XXX.WebPlants
      Orchard.Web\Modules\XXX.WebPlants\Views\Parts\TaxonomyNode.cshtml:62 Cannot resolve area 'XXX.WebPlants'
    
  Solution Orchard.sln
    Project XXX.WebPlants
      Orchard.Web\Modules\XXX.WebPlants\Views\Parts\TaxonomyNode.cshtml:93 Cannot resolve partial view 'HtmlPropertyDisplay'
    
  Solution Orchard.sln
    Project XXX.WebPlants
      Orchard.Web\Modules\XXX.WebPlants\Views\Parts\TaxonomyCatalogTree.cshtml:15 Cannot resolve partial view 'TaxonomyCatalogTreeNode'
    
I've tried with no success:
  • Putting ProjectTypeGuid: {349c5851-65df-11da-9384-00065b846f21};{fae04ec0-301f-11d3-bf4b-00c04f79efbc}
  • Removing _Resharper.Orchard folder
Does anyone know how to resolve those issues?