This project is read-only.

oForm, Email definitions

Topics: General
Jul 22, 2012 at 3:19 PM

I'm NOT receiving any msgs in ''  with below definitions.
PS: when sending a msg from my gmail to - I receive it correctly.

Orchard 1.4.2
Modules installed and active: oForm 1.8.1, Email Messaging and Messaging.
PS: the form shows correctly

In dashboard 'Email':
Sender email address:
Host Name:
Port: 25
credentials: PW: yxz

Modify oform:
Email Settings:  ? do I need to set anything here !?

thanks for your time and hints

Jul 23, 2012 at 6:54 PM

Try with a simple rule to see if you can send e-mail at all or if it's oform that's behaving. If you still can't send e-mail this way, you probably got the settings wrong. You can then look for errors in app_data\logs, and also check with your hosting company that the settings are fine, that there are no firwall rules blocking it, or anything of the sort.

Jul 24, 2012 at 8:32 AM

yes, I agree, there must be something wrong with the settings ... I think I tried almost every combination!

I talked to the Winhost; all seems ok; the do not block Port25; I can send msgs via my gmail account.

And, I do NOT have any error msgs in my App_data LOG!

 ??? One thing; when using in Dashboard Email > 'Require Credentials': any PW I give comes back BLANK after 'Enregistrer' ; is this correct??

Thanks for your help, ed



Jul 24, 2012 at 1:11 PM

Yes, it's normal that the password is not sent back. Pretty much all modern platforms work that way.

Did you try my suggestion to try to send mail using something else than oForms, such as rules?

Jul 25, 2012 at 1:59 PM
Edited Jul 25, 2012 at 2:14 PM

Hi Bertrand, thanks for your time ..

no, I did not try to send mail via 'rules' ... I didn't even realise that something like this exists! So, I first have to learn how to do this ...
Is there any Doc for this? I found something from david Haydn but I cannot see the 'email rule'. The Rules module however is activated!?

I had several converstaions with WinHost; the last comment being:
I checked the logs on the mail server and did not find any entry indicating that the connection to the smtp server was made.
I also check your web.config file on your site and found out that your mailSettings configurations are empty. It does not look like your Orchard application is propely configured to use your smtp settings. Please review your smtp settings in your web applicaiton and if still no success sending out messages, please contact the developers of this web application for further assistance.
END quote

... by the way  ... I wouldn't mind to give you guys once a temporary 'admin' ID to check this; it seems I'm the only one NOT succeeding with this oForm!

again thanks for your advise, ed

PS: Id rather change to 1.5, but this needs to run first!?




Jul 26, 2012 at 2:39 PM

WinHost people don't know what they're talking about: in Orchard, the e-mail configuration is not stored in web.config.

There isn't much documentation about rules, but it is pretty straightforward: add a rule, trigger it on content publication, and make it send an e-mail. Then publish a dummy page and see what happens.

Jul 26, 2012 at 4:35 PM

thanks a lot, I'm able to send a message i.e it arrives correctly ? Quite a good tool for many things !

? which Module is used to send this ?

That narrows the issue to my parameters in the 'E-mail Messaging' Module used for oForm, or oForm itself.
Guess I have to bother the oForm  and/or Winhost guys.

thanks for this hint, ed



Jul 26, 2012 at 4:48 PM

Yes. The email messaging is exposing this I think. You might also want to consider moving those forms to the new Custom Forms from Orchard 1.5.

Jul 26, 2012 at 5:46 PM

I'd love to change to 1.5 forms BUT for some special reasons I should have this 'Contact' page in 1.4.2!?

would it be possible to retrofit the 1.5 forms to 1.4.2!? any special procedure?

thanks anyway for all your help, ed

Jul 26, 2012 at 6:13 PM

Well, that would be awfully close to upgrading. You can try, but it's at your own risk...

Jul 26, 2012 at 8:50 PM

Bertrand, thanks for your time ..

... then i wait for 1.5; in fact I already converted it to 1.5 .. but as said there are other reasons why I'm not deployeng (yet) 1.5

Thanks for your help and consider this thread closed