Can't Install on Windows 7 x64 IIS 7.5

Topics: General, Installing Orchard
Jul 15, 2012 at 8:30 PM
Edited Jul 15, 2012 at 8:39 PM

I followed the following steps:

1. Download 1.5 RC2 zip file to my desktop from

2. Extract zip file to C:\Orchard

3. Set directory permissions on C:\Orchard so that DefaultAppPool and IIS_IUSRS have full access on the whole directory tree.

4. Open IIS Manager

5. Right click > Add Web Site

6. Site name: Orchard, Physical Path: C:\Orchard\Orchard, Type: http, IP Address: All Unassigned, Port: 80, Host name: orchard

7. Added orchard to my hosts file

8. Go to Application Pools > Orchard > Advanced Settings...set .NET Framework Version to v4.0, Managed Pipeline Mode to Integrated, Identity to ApplicationPoolIdentity

9. Navigate to http://orchard/

10. Page comes up, but no images appear, no css is applied, and javascript is not loaded. Navigating manually to any image urls or css links when viewing source yields:

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /Themes/SafeMode/scripts/html5.js

for example.


I've verified in Programs and Features that I have Static Content enabled

I've tried running caspol C:\Windows\Microsoft.NET\Framework64\v4.0.30319\CasPol.exe -m -ag 1 -url "file:////C:\Orchard\Orchard*" FullTrust -exclusive on

 I don't have UAC turned on

I've run C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -i

I've tried "Replace all child object permissions...."

I've tried restarting, iisreset, recylcing app pool etc.

No errors are logged in the Event Viewer.

Any idea why this most basic scenario doesn't work?

Jul 16, 2012 at 10:14 PM

Something is definitely off with your IIS configuration but I can't see what from this information.

Did you try a plain image in another, empty site?

Jul 16, 2012 at 11:21 PM

I did. Oddly, after I ran the Orchard recipe setup wizard...all the problems vanished and the site worked as normal...