RelationSample enabled but content types not available

Topics: Troubleshooting
Jun 6, 2012 at 10:46 PM

Hi, I have Orchard 1.4 installed and I have downloaded the file Orchard.Module.RelationSample.0.5.0.zip as explained in the online tutorial at http://docs.orchardproject.net/Documentation/Creating-1-n-and-n-n-relations

However, when I enable the module I am not getting the content types available in the content section.

Does this sample work with 1.4 ?

How can I troubleshoot this, any pointers gratefully received.

If any better examples on 1-n, n-n, gratefully received, thanks

 

Anthony

Coordinator
Jun 8, 2012 at 5:52 AM

Anything in app_data\logs?

Jun 10, 2012 at 8:13 PM

Thanks Bertrandleroy, bu no theere wasnt.

As I am not 100% sure I am doing things properly, I explain my steps below

1. Download and install latest version of orchard - now using 1.4.2

2. Download the relationship sample: http://docs.orchardproject.net/Attachments/Creating-1-n-and-n-n-relations/Orchard.Module.RelationSample.0.5.0.zip

3. Extract the relationship sample into Modules directory in a folder I create called Orchard.Module.RelationSample

4. In Orchard, I go to the Modules sections and I see that RelationSample appears TWICE, once in the "Sample" category and once in "Uncategorized"

5. If I turn either one on, or both then still, no new content types appear 

6. I look in app_data\logs and I see an empty log file dated today, but it is empty, nada...

Am i doing something obviosuly wrong?

Jun 10, 2012 at 8:31 PM

WORKS!

Put it instead in a folder called RelationSample 

Thanks!