This project is read-only.

Windows Azure: Server Error in '/' Application

Topics: Installing Orchard
Jun 5, 2012 at 3:13 PM

Hi my orchard cms project is getting the server error in '/' application on windows azure.

The first install of the application resulted in loading of the orchard setup screen and the application was working fine until I made a mistake with sql storage connectionstring by miss matching the dataconnection string during setup. Due to which, i was not able to complete the setup process thus running into issues, I have deleted the deployment (updated) multiple times but nothing seems to be resolving the issue.

On the sql azure, I ran a drop all objects to get rid of the tables, so that I can start fresh, could that have played any role in this issue?


The local "ServiceConfiguration.cscfg" has a (serviceName="OrchardCloudService") but the one under azure management is (serviceName="") and editing the config under azure management results is no change.

Same question on windows forum:

Jun 5, 2012 at 9:54 PM

You need to go to the blob storage and erase everything, and also in the database.

Jun 5, 2012 at 10:19 PM

Do I delete all these items under the storage account?

If so can I get some help in deleting these items? In visual studio 2010 the delete option is grayed out.




Jun 5, 2012 at 10:38 PM

The /sites at least. 

You can use some other tools then, like

Jun 5, 2012 at 11:48 PM

That resolved the issue, but re-running the "Get Started" is way too slow, stuck on "Cooking Orchard Receipe..." for almost 15+ minutes.

I am afraid to stop or refresh as this could go into same issue. I am using IE 9 browser.

Jun 6, 2012 at 12:00 AM

If it's a standard recipe that's not normal, I would suspect an issue with Azure. 

By the way please save the date:

You will like it.

Jun 6, 2012 at 12:12 AM

Thanks, I already signed up for the meet.

I am using the default recipe so not sure why this is acting this way, stuck on same screen for more than half hour now...

some times when I use jquery the IE acts differently, was I suppose to run this in the compatability mode of IE 9 due to jquery scripts getting stuck?

It is past 7 pm now and still at work so will have to stop the process, hope the azure install will work out the next time.

Thanks for the help.

Jun 6, 2012 at 12:17 AM

Ahh back to same issue after stopping (Server Error in '/' Application), looks like I should use different browser, as I suspect it to be custom IE 9 javascript issue if others have not ran into this issue.

Jun 6, 2012 at 12:22 AM

I have never had any issue with IE. This should be a problem at all.

Jun 6, 2012 at 9:14 PM

I ran the clean install again today but it ran into "Request timed out." error.

check the second image under this album ""

I will update my svn and see if I can rebuild the package to see if something strange has happened in the build and package process.


Jun 8, 2012 at 10:21 PM

I used the new portal and new install features of the web site gallery and everything worked out fine.

Do I no longer need a storage account? as I didn't create a storage account and just used the sql azure account connection string at "Getting Started" and everything installed fine.

I think my previous errors may have been related to "user id=username@server" as I may have forgotten and used "user id=username" and not including the "@servername", but than sql azure should not have had any tables if login was a failure... hmmm not sure...

Anyway now the site is live so it's not a issue for me any more and the great part is I don't have to run the "clicktobuild..." or upload, everything is just clicks away from the new website gallery. Awesome.

Jun 8, 2012 at 10:24 PM

With Azure Web Sites, no need for Blog storage, it's persistent storage, a standard file system. So even Sql Ce works just fine. Though using Sql Server will be better for performance.