SMTP not working using localhost

Topics: Customizing Orchard, Troubleshooting
Jun 4, 2012 at 4:18 PM
Edited Jun 4, 2012 at 4:19 PM

Hi,

I had read this article regarding Custom Form. I am using Orchard 1.4.2

http://devdirective.com/post/160/how-to-create-custom-forms-in-orchard-cms-with-email-and-recaptcha

And I guess I got it right.

But now, when I tested the Email Messaging wherein the form will send its details into my email it won't work. Btw, I already did the Rules.

Under Admin > Settings > Email, I input these configuration (I used gmail):

  • Sender Email Address: [sample]@gmail.com
  • Host Name: smtp.gmail.com
  • Port Number: 465
  • I checked "Enable SSL communications"
  • My creditials are:
    • Username - [sample]@gmail.com
    • Password - [myownpassword]

What's wrong with my configuration then?

Why is that I can't receive any new emails on my gmail account.

Please help me with these. Thank you.

Developer
Jun 4, 2012 at 6:37 PM

Perhaps an error occurs when the email is being sent. If so, you should see that in the Orchard log files.

Jun 5, 2012 at 1:25 PM

Where can I find this log file?

Jun 5, 2012 at 2:47 PM

I guess the answer resolves here...

http://orchard.codeplex.com/discussions/347819

 

My configuration is...

  • host name: smtp.gmail.com
  • port: 587
  • enable SSL

 

It works!

Feb 17, 2013 at 8:19 PM
Edited Feb 17, 2013 at 8:19 PM
Thanks a lot! I had the same issue.
Nov 19, 2014 at 5:29 AM
Hi All,

Here is a tip may help someone else encountered the same issue as me...
If you are using google smtp, please lower your google security level by enabling "Access for less secure apps" in your google account.
I hope it helps!