This project is read-only.

Orchard start page is now browsing to Directory Listing -- /OrchardLocal/

Topics: Troubleshooting
May 5, 2012 at 4:08 PM

I'm not sure what happened exactly.  I was happily coding along, working on a module, when one time when I pressed F5 to debug the app it navigates to the "Directory Listing" page instead of the start page.  I have been working with Orchard for the past several months and never had this issue.  I have tried cleaning solution, restarting computer, etc - all the obvious things.  

The url is:


which is the same as it was before.  The page title is:

Directory Listing -- /OrchardLocal/ 

with all the dirs/files listed below. 


What could be wrong here?  How can I set (reset) the start page?

May 5, 2012 at 5:43 PM

Did you check logs (/app_data/logs/)?

May 5, 2012 at 6:43 PM

ah!  Found my error in there.  thanks!

May 29, 2012 at 3:13 PM

What was the error tone33?

Just for the sake of anyone googling this issue - I have my local Sql server set to start manually, easy to fix but trips me up every time :)

Aug 5, 2012 at 10:51 PM

Apologies for not posting the solution...wishing I had now especially since I have run into this issue again after moving to a new development machine.  The error in my logs indicates a db connection issue, but going through pinal dave's list of suggested fixes for this sql error (see snippet from my log below) I still cannot get it to work.. perhaps I need to restart..  I am running Sql Server 2012 Developer edition. 


2012-08-05 16:46:34,415 [13] Orchard.Environment.DefaultOrchardHost - A tenant could not be started: DefaultSystem.Data.SqlClient.SqlException (0x80131904): A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

Aug 5, 2012 at 11:24 PM

Sooo.... my specific issue had to do with having my connection string wrong..  I have multiple connection strings and I missed changing one.  


The reason I have multiple connection strings, should anyone ask, is that I have the need to tie into an existing database and have not yet implemented using only one connection string - for some reason I got it to work with 2 and just haven't circled back to clean things up yet.

Oct 1, 2014 at 8:53 PM
haha.. it just happened to me... and as mentioned before, it is just an error!!
I tried to inject ISite interface in order to get the url base from a none context call... the thing is that i think ISite does not inherit from IDependency, and I think Orchard can't resolved, but this happens in the very begining coz this kind of issue let me flat with that listing directory. In the past i thought it was some kind of corrupting, and the problem was resolved setting everything up.